ホーム > フォーラム > 質問箱 > Xsns でファイルアップロードが出来ない

Xsns でファイルアップロードが出来ない
投稿者: avocet | 投稿日時: 2015/8/28 11:05 | 閲覧: 4872回
avocet

お世話になっております。

  xsns1.14 を使い始めましたがトピックを作成しファイルを添付しても反映(アップロード)されません。
 原因として何が考えられるでしょうか? よろしくお願いいたします。
 IE11 、chrome でも同じでした。

 環境は以下です。

Distribution : XOOPS X(ten) 20150425

XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1

使用言語 : ja_utf8
デバッグモードを有効にする : オフ

オペレーティングシステム : Linux w

サーバー : Apache
ユーザーエージェント : Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko

PHPバージョン : 5.3.3
MySQLのバージョン : 5.1.73

コメント(2)

新しいものから | 古いものから | ネスト表示 | RSS feed
Re: Xsns でファイルアップロードが出来ない 
投稿者: avocet | 投稿日時: 2015/8/28 11:58
avocet

追記です。

 xsns の一般設定で「アップロードを許可するファイルのMIMEタイプ」を以下のように設定していましたので、“.docx”は当然アップロード出来ると思っていましたので、“.docx”でテストをしたのですが、失敗。
 試しに“.jpg”や“.doc”でやってみたらアップロード出来ました。以下の「MIMEタイプ」の設定は間違っているのでしょうか?
 ご教示よろしくお願いいたします。

「text/plain|application/msword|application/vnd.ms-excel|application/vnd.ms-powerpoint|application/pdf|image/jpeg|application/zip|application/vnd.openxmlformats-officedocument.wordprocessingml.document|application/vnd.openxmlformats-officedocument.spreadsheetml.sheet|application/vnd.openxmlformats-officedocument.presentationml.presentation」

引用:
お世話になっております。

  xsns1.14 を使い始めましたがトピックを作成しファイルを添付しても反映(アップロード)されません。
 原因として何が考えられるでしょうか? よろしくお願いいたします。
 IE11 、chrome でも同じでした。

 環境は以下です。

Distribution : XOOPS X(ten) 20150425

XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1

使用言語 : ja_utf8
デバッグモードを有効にする : オフ

オペレーティングシステム : Linux w

サーバー : Apache
ユーザーエージェント : Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko

PHPバージョン : 5.3.3
MySQLのバージョン : 5.1.73

Re: Xsns でファイルアップロードが出来ない 
投稿者: avocet | 投稿日時: 2015/8/28 13:10 | 親コメント: #21526
avocet

すみません、自己解決しました。

 xsns に同梱の readme.html に書いてありました。
 XOOPS_ROOT_PATH/class/mimetypes.inc.php に mimetype を追記しなければならなかったのですね。
 これで解決しました。お騒がせしました。

 添付ファイルに日本語のファイル名を付けると、保存の時に文字化けしてしまいます。サイトが UTF-8 のせいでしょうか?
 これは別スレッドで質問させていただきます。

引用:
追記です。

 xsns の一般設定で「アップロードを許可するファイルのMIMEタイプ」を以下のように設定していましたので、“.docx”は当然アップロード出来ると思っていましたので、“.docx”でテストをしたのですが、失敗。
 試しに“.jpg”や“.doc”でやってみたらアップロード出来ました。以下の「MIMEタイプ」の設定は間違っているのでしょうか?
 ご教示よろしくお願いいたします。

「text/plain|application/msword|application/vnd.ms-excel|application/vnd.ms-powerpoint|application/pdf|image/jpeg|application/zip|application/vnd.openxmlformats-officedocument.wordprocessingml.document|application/vnd.openxmlformats-officedocument.spreadsheetml.sheet|application/vnd.openxmlformats-officedocument.presentationml.presentation」

引用:
お世話になっております。

  xsns1.14 を使い始めましたがトピックを作成しファイルを添付しても反映(アップロード)されません。
 原因として何が考えられるでしょうか? よろしくお願いいたします。
 IE11 、chrome でも同じでした。

 環境は以下です。

Distribution : XOOPS X(ten) 20150425

XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1

使用言語 : ja_utf8
デバッグモードを有効にする : オフ

オペレーティングシステム : Linux w

サーバー : Apache
ユーザーエージェント : Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko

PHPバージョン : 5.3.3
MySQLのバージョン : 5.1.73

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top