XOOPS Cube日本サイト (XCL2.1.7) http://xoopscube.jp/forum?category_id=27&keyword= 最新公開記事 Warning: require_onceというエラー http://xoopscube.jp/forum/7238 OOPS Cube Legacy 2.1.7サーバーXREA+(PLUS)2009年頃XOOPSをインストールして、それから問題なく稼働していましたが、FTPソフトで、間違ってファイルをいくつか消してしまいました。トップページは403になるし、モニタも頭も真っ白に!2009年頃バックアップしていたデータがあったので、それをちょこちょこアップロードし、元に戻そうとしましたが、やはりサイトが表示されません。Warning: require_once(/virtual/ユーザID/xoops_trust_path/modules/wizxc/class/Legacy_WizXcController.class.php) [function.require-once]: failed to open stream: No such file or directory in /virtual/ユーザID/public_html/core/XCube_Root.class.php on line 533Fatal error: require_once() [function.require]: Failed opening required '/virtual/ユーザID/xoops_trust_path/modules/wizxc/class/Legacy_WizXcController.class.php' (include_path='.:/usr/local/lib/php') in /virtual/ユーザID/public_html/core/XCube_Root.class.php on line 533HTMLとCSSは分かるけど、自力でphpは書いた事がなく、本で調べながらインストールから表示部分のカスタマイズは出来たというレベルです。このエラーを調べてみたところ、Legacy_WizXcController.class.phpというファイルがないよ、という事が書いてあるのでしょうか?public_htmlの上に、XOOPS_TRUST_PATHがあって、そこにLegacy_WizXcController.class.phpはあります。このサイトとは別のアドレスで、XOOPS Cube Legacy 2.1.5をインストールしたサイトも持っており、ディレクトリ構造も似ている事から、アップロードしたデータが間違っていた可能性もなきにしもあらずです。XREAが2014.12〜2015.6までにバージョンアップメンテナンスを実施し、  MySQLサーバーのバージョンアップ(5.6系へ変更)  標準のPHPのバージョンアップ(PHP5.2系 → PHP5.3系へ変更)・・・他XOOPS Cube Legacy 2.1.5で作ったサイトが見れなくなっていたことに気づきました。慌ててデータを修正しようとあれこれいじりましたが、逆に間違ったコードで上書きしている恐れがあります。ということから、XOOPS Cube Legacy 2.1.5の復旧はほぼ諦めています。しかし、冒頭のXOOPS Cube Legacy 2.1.7のサイトは、バージョンアップメンテナンス後である7月初旬に見れました。最近の投稿記事は諦めるとしてもなんとか見れるようにしたいのです。皆様お知恵を貸していただけませんでしょうか。よろしくお願いいたします。

OOPS Cube Legacy 2.1.7
サーバー
XREA+(PLUS)

2009年頃XOOPSをインストールして、それから問題なく稼働していましたが、
FTPソフトで、間違ってファイルをいくつか消してしまいました。
トップページは403になるし、モニタも頭も真っ白に!
2009年頃バックアップしていたデータがあったので、
それをちょこちょこアップロードし、元に戻そうとしましたが、
やはりサイトが表示されません。

Warning: require_once(/virtual/ユーザID/xoops_trust_path/modules/wizxc/class/Legacy_WizXcController.class.php) [function.require-once]: failed to open stream: No such file or directory in /virtual/ユーザID/public_html/core/XCube_Root.class.php on line 533

Fatal error: require_once() [function.require]: Failed opening required '/virtual/ユーザID/xoops_trust_path/modules/wizxc/class/Legacy_WizXcController.class.php' (include_path='.:/usr/local/lib/php') in /virtual/ユーザID/public_html/core/XCube_Root.class.php on line 533

HTMLとCSSは分かるけど、自力でphpは書いた事がなく、
本で調べながらインストールから表示部分のカスタマイズは出来たというレベルです。

このエラーを調べてみたところ、Legacy_WizXcController.class.phpというファイルがないよ、という事が書いてあるのでしょうか?
public_htmlの上に、XOOPS_TRUST_PATHがあって、そこにLegacy_WizXcController.class.phpはあります。

このサイトとは別のアドレスで、
XOOPS Cube Legacy 2.1.5をインストールしたサイトも持っており、
ディレクトリ構造も似ている事から、
アップロードしたデータが間違っていた可能性もなきにしもあらずです。

XREAが2014.12〜2015.6までにバージョンアップメンテナンスを実施し、
  MySQLサーバーのバージョンアップ(5.6系へ変更)
  標準のPHPのバージョンアップ(PHP5.2系 → PHP5.3系へ変更)・・・他
XOOPS Cube Legacy 2.1.5で作ったサイトが見れなくなっていたことに気づきました。
慌ててデータを修正しようとあれこれいじりましたが、
逆に間違ったコードで上書きしている恐れがあります。
ということから、XOOPS Cube Legacy 2.1.5の復旧はほぼ諦めています。
しかし、冒頭のXOOPS Cube Legacy 2.1.7のサイトは、
バージョンアップメンテナンス後である7月初旬に見れました。
最近の投稿記事は諦めるとしてもなんとか見れるようにしたいのです。

皆様お知恵を貸していただけませんでしょうか。
よろしくお願いいたします。

]]>
ayashow 2015-07-20T00:59+09:00 XCL2.1.7
コンフィグのメール設定だけが開けなくなりました http://xoopscube.jp/forum/7224 soyogiです。ContactCenterを使用していて、内容等はXOOPS上で確認できるのですが、メールが届かないという症状が最近になって出て調べたところ、XOOPS管理メニュー → 互換モジュール → XOOPSコンフィグ → メール設定の画面だけ開けず真っ白になってしまっていました。(他のコンフィグカテゴリのメニューは開けます)検索して調べてみて、php.iniの「memory_limit」かなと当たりはつけて128M→256Mにしてみて、httpdを再起動したのですが変化なしでした。環境としてはCentOS release 6.4 (Final)Apache 2.2.15XOOPS ホダ塾(XCL 2.1.7)PHP 5.2.17ContactCenter 0.98デバッグモードで見てみるしかないでしょうか。結構なユーザーが使用しているサイトなので、デバッグにするタイミングが中々取り辛く…問題はContactCenterではなく、メール設定が開けないからメールが送れてないのだとは思いますが、真っ白画面なので何も出来ずでして。何か情報があればご教示お願い出来ますでしょうか。

soyogiです。

ContactCenterを使用していて、内容等はXOOPS上で確認できるのですが、メールが届かないという症状が最近になって出て調べたところ、
XOOPS管理メニュー → 互換モジュール → XOOPSコンフィグ → メール設定
の画面だけ開けず真っ白になってしまっていました。
(他のコンフィグカテゴリのメニューは開けます)

検索して調べてみて、php.iniの「memory_limit」かなと当たりはつけて128M→256Mにしてみて、httpdを再起動したのですが変化なしでした。

環境としては
CentOS release 6.4 (Final)
Apache 2.2.15
XOOPS ホダ塾(XCL 2.1.7)
PHP 5.2.17
ContactCenter 0.98

デバッグモードで見てみるしかないでしょうか。
結構なユーザーが使用しているサイトなので、デバッグにするタイミングが中々取り辛く…

問題はContactCenterではなく、メール設定が開けないからメールが送れてないのだとは思いますが、真っ白画面なので何も出来ずでして。
何か情報があればご教示お願い出来ますでしょうか。

]]>
soyogi 2015-01-07T12:52+09:00 XCL2.1.7
Analyzer for XCのダウンロードができません http://xoopscube.jp/forum/7190 このサイトの「モジュール」のところから、Analyzer for XCの最新のダウンロードリンクをクリックすると「ぶろぐ Take it easy」というページに飛びますが、そこには、ダウンロードできるような場所が見つかりません。また、「Analyzer(XOOPS_TRUST_PATH専用)}のダウンロードリンクから、http://marijuana.ddo.jp/へ飛んだあと、そのページのダウンロードのリンクをクリックするとMcAfeeSiteAdviserが、「ダウンロードキーが不正です」というメッセージを出して、「危険なサイトです」と警告して来ます。ダウンロードの方法が間違っているのでしょうか?

このサイトの「モジュール」のところから、Analyzer for XCの最新のダウンロードリンクを
クリックすると「ぶろぐ Take it easy」というページに飛びますが、そこには、ダウンロード
できるような場所が見つかりません。

また、「Analyzer(XOOPS_TRUST_PATH専用)}のダウンロードリンクから、http://marijuana.ddo.jp/へ飛んだあと、そのページのダウンロードのリンクをクリックすると
McAfeeSiteAdviserが、「ダウンロードキーが不正です」というメッセージを出して、
「危険なサイトです」と警告して来ます。

ダウンロードの方法が間違っているのでしょうか?

]]>
Beginner_K 2014-02-26T09:58+09:00 XCL2.1.7
求人ポータル構築 http://xoopscube.jp/forum/7076 求人ポータルの構築を考えております。1つは求職者側、もうひとつは求人側と二つのXoopsをインストールし求職者側は自分の情報をデータベースに登録、求人側の情報を検索、求人側は自分の情報をデータベースに登録、求職側の情報を検索とういうようなサイトを考えております。お互いに登録した情報を検索することは可能でしょうか?よろしくお願いいたします。 求人ポータルの構築を考えております。

1つは求職者側、もうひとつは求人側と二つのXoopsをインストールし
求職者側は自分の情報をデータベースに登録、求人側の情報を検索、
求人側は自分の情報をデータベースに登録、求職側の情報を検索
とういうようなサイトを考えております。

お互いに登録した情報を検索することは可能でしょうか?

よろしくお願いいたします。]]>
nacht 2012-12-17T11:06+09:00 XCL2.1.7
xhnewbb1.31 にて新規トピックが追加できない http://xoopscube.jp/forum/7061 現在、xhnewbb1.31にてフォーラムを立てていたのですが、突然「■このフォーラムはコメント用フォーラムです。新規トピックはたてられません」というメッセージが出てしまい、トピックがたてられなくなってしまいました。こちらの原因はお分かりになりますでしょうか。また、トピックの上限数があるのであれば変更して、トピックを立てられるように変更する事は可能でしょうか。誠に恐縮ですが、お教え頂けますと幸いです。【利用環境】XoopsVersion2.1.7利用サーバ:さくらインターネット 現在、xhnewbb1.31にてフォーラムを立てていたのですが、
突然「■このフォーラムはコメント用フォーラムです。新規トピックはたてられません」というメッセージが出てしまい、トピックがたてられなくなってしまいました。

こちらの原因はお分かりになりますでしょうか。

また、トピックの上限数があるのであれば変更して、トピックを立てられるように変更する事は可能でしょうか。

誠に恐縮ですが、お教え頂けますと幸いです。

【利用環境】
XoopsVersion2.1.7
利用サーバ:さくらインターネット]]>
taguchi 2012-09-27T00:11+09:00 XCL2.1.7
[XCL2.1.7]ドメイン変更時のURL修正について http://xoopscube.jp/forum/7011 現在XCL2.1.7で運用しているサイトで独自ドメインの変更作業があります。サイト全体の変更については問題ないのですが、webphoto/D3blogモジュール内に絶対パスで画像リンクを書いている記事が多数存在します。その際の効率的な作業方法について模索しています。現在の作業案としては・DBからD3blog/Webphotoの記事本文が収められているテーブルを抜き出し URL記述を一括で置き換えというのが最良かな、と考えていますが何分DBに疎い為、もう少し簡単なやり方があるよーという方がいれば参考にしたいなと思っています(笑)それではご回答を募集しております。 現在XCL2.1.7で運用しているサイトで独自ドメインの変更作業があります。
サイト全体の変更については問題ないのですが、webphoto/D3blogモジュール内に
絶対パスで画像リンクを書いている記事が多数存在します。
その際の効率的な作業方法について模索しています。

現在の作業案としては
・DBからD3blog/Webphotoの記事本文が収められているテーブルを抜き出し
 URL記述を一括で置き換え

というのが最良かな、と考えていますが何分DBに疎い為、もう少し簡単な
やり方があるよーという方がいれば参考にしたいなと思っています(笑)

それではご回答を募集しております。]]>
tonoibito 2012-04-11T09:29+09:00 XCL2.1.7
Legacy2.1.7での管理画面が真っ白です。 http://xoopscube.jp/forum/7010 Package_Legacy_2_1_7を採用しています。管理者としてログインでき、各モデュールも動作しています。但し、管理画面が真っ白になり、VerUp等の作業ができません。エラーを見ると以下の通りでした。Fatal error: Class 'Legacy_AdminActionSearch' not found in /virtual/muraplus/public_html/modules/legacy/kernel/Legacy_AdminControllerStrategy.class.php on line 85で、該当の85行を見ると$this->mController->_mBlockChain[] =& new Legacy_AdminActionSearch():これはどういう意味で、解決方法はありますか? Package_Legacy_2_1_7を採用しています。
管理者としてログインでき、各モデュールも動作しています。

但し、管理画面が真っ白になり、VerUp等の作業ができません。
エラーを見ると以下の通りでした。

Fatal error: Class 'Legacy_AdminActionSearch' not found in /virtual/muraplus/public_html/modules/legacy/kernel/Legacy_AdminControllerStrategy.class.php on line 85

で、該当の85行を見ると
$this->mController->_mBlockChain[] =& new Legacy_AdminActionSearch():

これはどういう意味で、解決方法はありますか?]]>
tarukuu 2012-04-10T16:28+09:00 XCL2.1.7
すぐに「サーバーエラー」になるのは、どのモジュールに原因がるのでしょうか? http://xoopscube.jp/forum/6977 下記のサイトを運営していますが、クリックするとすぐに「サーバーエラー」になってしまい。再度読みこみをしなければなりません。D3blogやwebphotoで書き込んで送信をしてもエラーが出て一度でできなくまた読み込まないといけなかったりします。サーバーの不安定なせいでしょうか。それともモジュールの設定ミスでしょうか。プロテクターもあちこち設定しなおしたので・・・・原因がどこにあるのか分かりません。どなたかご教授ください。 奄美の風サイトhttp://amaminokaze.com/htmlです。 サーバーの環境は以下の通りです。レンタルサーバーはtok2プロです。環境チェックOS: Linux prosv8.tok2.com 2.6.18-194.17.1.el5.centos.plusxen #1 SMP Thu Sep 30 20:56:28 EDT 2010 i686PHP: 5.2.6MySQL: 5.0.77-logXOOPS: XOOPS Cube Legacy 2.1.7Webphoto: 2.32 下記のサイトを運営していますが、クリックするとすぐに「サーバーエラー」になってしまい。再度読みこみをしなければなりません。

D3blogやwebphotoで書き込んで送信をしてもエラーが出て一度でできなくまた読み込まないといけなかったりします。サーバーの不安定なせいでしょうか。

それともモジュールの設定ミスでしょうか。

プロテクターもあちこち設定しなおしたので・・・・

原因がどこにあるのか分かりません。

どなたかご教授ください。

 奄美の風サイト

http://amaminokaze.com/html

です。

 サーバーの環境は以下の通りです。レンタルサーバーはtok2プロです。

環境チェック
OS: Linux prosv8.tok2.com 2.6.18-194.17.1.el5.centos.plusxen #1 SMP Thu Sep 30 20:56:28 EDT 2010 i686
PHP: 5.2.6
MySQL: 5.0.77-log
XOOPS: XOOPS Cube Legacy 2.1.7
Webphoto: 2.32]]>
jo6gsd 2012-02-09T17:58+09:00 XCL2.1.7
モジュールがインストールできないのは phpファイルのエラー、どこを修正すればいいのでしょうか。 http://xoopscube.jp/forum/6975 警告[PHP]:必要とする(/ home/member/jo6gsd/public_html/xoops_trust_path/modules/d3pipes/xoops_version.php)[ function.require ]:失敗したストリームを開く:ファイルmodules/d3pipes/xoops_versionでそのようなファイルやディレクトリはありません。 phpの9行目 モジュールがインストールしようとしたら、上のようなメッセージが出てきました。どうもd3pioersをサーバーから削除したつもりなのにまだ残っているようです。サーバーのファイルを見ても、modulesのフォルダのなかにd3pioesのファイルはみつかりません。このxoops_version.phpファイルはどこにあるのでしょう。どなたかご教授願えませんでしょうか。「奄美の風」サイトです。  http://amaminokaze.com/html私が使っているレンタルサーバーの環境は次の通りです。環境チェックOS: Linux prosv8.tok2.com 2.6.18-194.17.1.el5.centos.plusxen #1 SMP Thu Sep 30 20:56:28 EDT 2010 i686PHP: 5.2.6MySQL: 5.0.77-logXOOPS: XOOPS Cube Legacy 2.1.7Webphoto: 2.32 警告[PHP]:必要とする(/ home/member/jo6gsd/public_html/xoops_trust_path/modules/d3pipes/xoops_version.php)[ function.require ]:失敗したストリームを開く:ファイルmodules/d3pipes/xoops_versionでそのようなファイルやディレクトリはありません。 phpの9行目

 モジュールがインストールしようとしたら、上のようなメッセージが出てきました。

どうもd3pioersをサーバーから削除したつもりなのにまだ残っているようです。

サーバーのファイルを見ても、modulesのフォルダのなかにd3pioesのファイルはみつかりません。このxoops_version.phpファイルはどこにあるのでしょう。

どなたかご教授願えませんでしょうか。

「奄美の風」サイトです。

  http://amaminokaze.com/html

私が使っているレンタルサーバーの環境は次の通りです。

環境チェック
OS: Linux prosv8.tok2.com 2.6.18-194.17.1.el5.centos.plusxen #1 SMP Thu Sep 30 20:56:28 EDT 2010 i686
PHP: 5.2.6
MySQL: 5.0.77-log
XOOPS: XOOPS Cube Legacy 2.1.7
Webphoto: 2.32]]>
jo6gsd 2012-02-05T08:17+09:00 XCL2.1.7
TOP画面が真っ白に http://xoopscube.jp/forum/6923 XOOPS CUBE L 2.1.7を使用していますが、今朝webphotoで写真を投稿していたらエラーになり再度、アクセスするとTOPの画面が真っ白で何も表示されません。対策はないでしょうか。サーバーのmaine.fileを見ても異常はなさそうなんですが。http://amaminokaze.com/html 「奄美の風」サイトです。どなたかご教示ください。『カスタマイジング・ズープス』を参考にしていますが対応のページはないようです。jo6gsd XOOPS CUBE L 2.1.7を使用していますが、今朝webphotoで写真を投稿していたらエラーになり再度、アクセスするとTOPの画面が真っ白で何も表示されません。

対策はないでしょうか。

サーバーのmaine.fileを見ても異常はなさそうなんですが。

http://amaminokaze.com/html 

「奄美の風」サイトです。どなたかご教示ください。『カスタマイジング・ズープス』を参考にしていますが対応のページはないようです。

jo6gsd]]>
jo6gsd 2011-12-10T07:36+09:00 XCL2.1.7
xhldが表示したりしなかったり・・・・ http://xoopscube.jp/forum/6851 お世話になりますxhldの事でお伺いしますXOOPS Cube Legacy 2.1.7でxhld3.08を使用していますが不安定で設定しているrssを表示したりしなかったり・・・・全然表示しないと言う事ではないんです以前は問題なく表示していたのですが、最近ほとんど表示しません忘れた頃にたまに表示する感じですこれを改善し常時rssを表示させたいと思っております。初心者で詳しい事がまったく分からず困っています。どうぞご教示いただきますようお願い申し上げます。よろしくお願いします。 お世話になります

xhldの事でお伺いします

XOOPS Cube Legacy 2.1.7でxhld3.08を使用していますが
不安定で設定しているrssを表示したりしなかったり・・・・
全然表示しないと言う事ではないんです

以前は問題なく表示していたのですが、最近ほとんど表示しません
忘れた頃にたまに表示する感じです

これを改善し常時rssを表示させたいと思っております。

初心者で詳しい事がまったく分からず困っています。

どうぞご教示いただきますようお願い申し上げます。


よろしくお願いします。]]>
moco2086 2011-06-14T04:36+09:00 XCL2.1.7
ゲームソフトのレビューサイトを作りたい http://xoopscube.jp/forum/6821 こんにちは 表題の通りです。ゲームのレビューを書いて記事を投稿するタイプのモジュールを探しています。そういうのであればブログ系のモジュールでいけそうなんですがサイトを見ている第三者でもレビュー記事を投稿出来るようにしたいと思っています。my-albumを以前使っていたのですがもうサイト新築にあたりもう少し簡単な(サイトの来訪者にとって)投稿ツールを探しています。条件としては・レビュー用画像が投稿出来る・サイト閲覧者が投稿出来る・出来ればコメントや点数を付けられるこういったモジュールがあれば教えてくださいませよろしくお願いします。 こんにちは 表題の通りです。

ゲームのレビューを書いて記事を投稿するタイプのモジュールを探しています。
そういうのであればブログ系のモジュールでいけそうなんですが
サイトを見ている第三者でもレビュー記事を投稿出来るようにしたいと思っています。
my-albumを以前使っていたのですがもうサイト新築にあたり
もう少し簡単な(サイトの来訪者にとって)投稿ツールを探しています。
条件としては
・レビュー用画像が投稿出来る
・サイト閲覧者が投稿出来る
・出来ればコメントや点数を付けられる

こういったモジュールがあれば教えてくださいませ
よろしくお願いします。]]>
kouchagoku 2011-02-23T22:18+09:00 XCL2.1.7
この投稿にアクセスする権限がありません(1.2) http://xoopscube.jp/forum/6818 超初心者の質問失礼します。XOOPS Cube Legacy 2.1.7にてPopnupblog(v3.23)を利用しているのですが、新規に登録を行ったユーザーによるブログの投稿ができなくなってしまいました。投稿画面にアクセスしようとすると「この投稿にアクセスする権限がありません(1.2)」と表示され、跳ね返されます。(ログインは問題無くできるのですが...)ユーザー登録は以前登録してあったユーザーと同じ設定、ユーザーグループも同じものに登録されているため、アクセス権限も同じはずなのですが...よろしくお願い致します。 超初心者の質問失礼します。

XOOPS Cube Legacy 2.1.7にてPopnupblog(v3.23)を利用しているのですが、
新規に登録を行ったユーザーによるブログの投稿ができなくなってしまいました。
投稿画面にアクセスしようとすると「この投稿にアクセスする権限がありません(1.2)」
と表示され、跳ね返されます。(ログインは問題無くできるのですが...)
ユーザー登録は以前登録してあったユーザーと同じ設定、ユーザーグループも同じものに登録されているため、
アクセス権限も同じはずなのですが...

よろしくお願い致します。]]>
lighten 2011-02-11T17:25+09:00 XCL2.1.7
ユーザー情報の文字数制限について http://xoopscube.jp/forum/6812 こんにちは。いつも参考にさせていただいております。現在ユーザー情報登録画面にて、ICQやAIMを利用して別項目として対応しております。その際ICQやAIMは半角15文字までの文字数制限があり文字数制限数を拡大するため、このフォーラムを参考に以下のファイルを変更しました。参考URL:http://xoopscube.jp/modules/newbb/viewtopic.php?post_id=46297&topic_id=9640&forum=14#forumpost462971.テーブルの項目定義 phpmyadminにてログインしテーブルを変更2.xoopsobject定義 kernel/user.phpにてicqとaimの文字数を変更3.ユーザー情報テンプレートの新規登録、編集画面も変更こうすることで、新規登録時は文字数制限が半角15文字以上でもエラーは出ずに送信できるようになりました。ただ、アカウント編集画面にて変更を行なって再保存をすると文字制限のエラーが表示されます。エラーメッセージ:ICQは半角15文字以内で入力して下さい。 他に対応すべき場所がございますでしょうか。もしご存知の方がいらっしゃいましたら教えていただきますようお願い致します。 こんにちは。
いつも参考にさせていただいております。

現在ユーザー情報登録画面にて、ICQやAIMを利用して別項目として対応しております。
その際ICQやAIMは半角15文字までの文字数制限があり文字数制限数を拡大するため、
このフォーラムを参考に以下のファイルを変更しました。

参考URL:http://xoopscube.jp/modules/newbb/viewtopic.php?post_id=46297&topic_id=9640&forum=14#forumpost46297

1.テーブルの項目定義 phpmyadminにてログインしテーブルを変更

2.xoopsobject定義 kernel/user.phpにてicqとaimの文字数を変更

3.ユーザー情報テンプレートの新規登録、編集画面も変更

こうすることで、新規登録時は文字数制限が半角15文字以上でもエラーは出ずに送信できるようになりました。
ただ、アカウント編集画面にて変更を行なって再保存をすると文字制限のエラーが表示されます。

エラーメッセージ:ICQは半角15文字以内で入力して下さい。


他に対応すべき場所がございますでしょうか。
もしご存知の方がいらっしゃいましたら教えていただきますようお願い致します。]]>
kana0325 2011-01-20T10:56+09:00 XCL2.1.7
ユーザーのuidについて http://xoopscube.jp/forum/6774 お世話になります。初めて投稿させて頂きますishi07と申します。xoops初心者です。宜しくお願い申し上げます。現在xoopsにてポータルサイトの作成を検討しております。会員を登録した時に、uidという値が自動的に割り振りされるようになっておりますが、この値を任意の文字列+数字(例えば ab-0000001)といった感じで連番を割り振る事は可能でしょうか?もし、uidで不可能ならば、代行案として何かありますでしょうか?xoopsのバージョンは XOOPS Cube Legacy 2.1.7です。何卒ご回答頂ければ幸いです。宜しくお願い申し上げます。 お世話になります。初めて投稿させて頂きますishi07と申します。
xoops初心者です。宜しくお願い申し上げます。

現在xoopsにてポータルサイトの作成を検討しております。
会員を登録した時に、uidという値が自動的に割り振りされるようになっておりますが、
この値を任意の文字列+数字(例えば ab-0000001)といった感じで連番を割り振る事は可能でしょうか?
もし、uidで不可能ならば、代行案として何かありますでしょうか?

xoopsのバージョンは XOOPS Cube Legacy 2.1.7です。

何卒ご回答頂ければ幸いです。
宜しくお願い申し上げます。]]>
ishi07 2010-08-30T15:29+09:00 XCL2.1.7
RSSCのcron設定 imagickの代わりにGDを使うには? http://xoopscube.jp/forum/6772 いま、ロリポップのレンタルサーバー上で、RSSCを動かそうとしています。モジュール自体はインストールできましたが、cron設定でrefresh.phpを動かすと、Unable to load dynamic library '/usr/lib/php/modules/imagick.so などのエラーがでます。ロリポップに問い合わせたところ、 お尋ね頂いた『imagick』についておそれいりますが、ロリポップ!レンタルサーバーでは『imagick』は導入致しておりません。その為、『GD』をご利用頂いております。よろしければご活用下さい。と、回答をいただきましたが、refresh.phpなどを変更して、GD対応にすることはできるのでしょうか? いま、ロリポップのレンタルサーバー上で、RSSCを動かそうとしています。
モジュール自体はインストールできましたが、cron設定でrefresh.phpを動かすと、Unable to load dynamic library '/usr/lib/php/modules/imagick.so などのエラーがでます。

ロリポップに問い合わせたところ、
 お尋ね頂いた『imagick』についておそれいりますが、
ロリポップ!レンタルサーバーでは『imagick』は導入致しておりません。

その為、『GD』をご利用頂いております。
よろしければご活用下さい。

と、回答をいただきましたが、refresh.phpなどを変更して、GD対応にすることはできるのでしょうか?]]>
IceLeopard 2010-08-26T16:11+09:00 XCL2.1.7
admin.php http://xoopscube.jp/forum/6714 先日レンタルサーバーのPF-X.NETにXCL2.1.7をインストールしたのですがインストール後のユーザーメニューから管理者メニューをクリックしても画面がメイン画面から変わりませんURLはhttp://domain/admin.phpになってるのでリンクは動いてるようですが・・・ユーザーメニューのその他項目は普通に動いていますエラーメッセージすら吐かないのでどうしたら良いのか分からずに困っています対処方法に心当たりのある方お助けくださると幸いです 先日レンタルサーバーのPF-X.NETにXCL2.1.7をインストールしたのですがインストール後のユーザーメニューから管理者メニューをクリックしても画面がメイン画面から変わりません
URLはhttp://domain/admin.phpになってるのでリンクは動いてるようですが・・・
ユーザーメニューのその他項目は普通に動いています
エラーメッセージすら吐かないのでどうしたら良いのか分からずに困っています
対処方法に心当たりのある方お助けくださると幸いです]]>
StarLight 2010-05-17T20:05+09:00 XCL2.1.7
インストール中管理画面にログインできない http://xoopscube.jp/forum/6635 hd_full_1_0_4をインストールする最中、ログイン画面になりから登録した管理者にてログインしようとすると、「○○さんようこそ」の画面になるのですが、管理画面は表示されず、ログイン画面に戻ってしまいます。その為、インストールが完了できず困っております。cachetemplate_cuploadmainfile.php上記のファイル等はレンタルサーバーのマニュアルにある通りパーミッション等の変更はしたのですが、ログインはできず原因が未だにわからないです。サーバー:iSLE infinitoPLUS(WindowsSERVER)XOOPS初心者で申し訳ないのですが、ご教授いただけますようよろしくお願いいたします。 hd_full_1_0_4をインストールする最中、ログイン画面になりから登録した管理者にてログインしようとすると、
「○○さんようこそ」の画面になるのですが、管理画面は表示されず、ログイン画面に戻ってしまいます。
その為、インストールが完了できず困っております。

cache
template_c
upload
mainfile.php

上記のファイル等はレンタルサーバーのマニュアルにある通り
パーミッション等の変更はしたのですが、ログインはできず
原因が未だにわからないです。

サーバー:iSLE infinitoPLUS(WindowsSERVER)

XOOPS初心者で申し訳ないのですが、ご教授いただけますよう
よろしくお願いいたします。]]>
taka302 2010-02-01T08:24+09:00 XCL2.1.7
QueryStringの値によって、Xoopsのテーマ内の複数のCSSやtheme.htmlファイルを切り替え http://xoopscube.jp/forum/6720 こんにちは。URLで例えば、http://www.abc.com/xoops/?css=sample1.cssなどのように、「css」変数にスタイルシート名を指定することにより、xoops画面のcssを切り替える方法についての質問です。当方では、$_GET['css']の値を、Smarty変数としてtheme.htmlファイルへ渡す方法を検討していました。例えば、theme.htmlでは以下のようにして、スタイルシートを切り替えることを考えていました。<link href="css/<{$css}>.css" rel="stylesheet" type="text/css" />やってはみたのですが、かなり汚いやり方になってしまいました。xoops/modules/legacy/kernel/Legacy_Controller.class.php内の_executeViewTheme()関数をいじり、$screenTarget->setAttribute('css',$_GET['css']);のようにして実現しています。しかし、これでは、Xoopsをアップグレードした際に問題ですし、そもそも悪影響がどこに出るかわかりません。他に適切なやり方がないか、お知恵を拝借したいと思い、投稿させていただきました。宜しくお願いします。 こんにちは。
URLで例えば、
http://www.abc.com/xoops/?css=sample1.css
などのように、「css」変数にスタイルシート名を指定することにより、
xoops画面のcssを切り替える方法についての質問です。

当方では、$_GET['css']の値を、Smarty変数としてtheme.htmlファイルへ渡す方法を検討していました。

例えば、theme.htmlでは以下のようにして、
スタイルシートを切り替えることを考えていました。

<link href="css/<{$css}>.css" rel="stylesheet" type="text/css" />


やってはみたのですが、かなり汚いやり方になってしまいました。
xoops/modules/legacy/kernel/Legacy_Controller.class.php内の_executeViewTheme()関数をいじり、

$screenTarget->setAttribute('css',$_GET['css']);

のようにして実現しています。

しかし、これでは、Xoopsをアップグレードした際に問題ですし、そもそも悪影響がどこに出るかわかりません。
他に適切なやり方がないか、お知恵を拝借したいと思い、投稿させていただきました。

宜しくお願いします。]]>
kabahandle 2010-05-28T11:51+09:00 XCL2.1.7
管理画面にログインできなくなりました!!(Plugg導入済) http://xoopscube.jp/forum/6707 突然管理画面にログインできなくなりました・・・http://サイトアドレス/user/login?return=1http://サイトアドレス/user/registerなどにアクセスすると500エラーになります。Plugg導入済のため、http://サイトアドレス/user.phpやhttp://サイトアドレス/admin.phpにアクセスしてもhttp://サイトアドレス/user/loginにリダイレクトされてしまいます。Pluggのプラグインのxiggやプロフページなどにはアクセスできます。http://サイトアドレス/xigg/1http://サイトアドレス/user/1Pluggの設定でmod_rewriteを有効にしていました。対応する.htaccessも設置しています。もちろんサーバのmod_rewriteは有効です。.htaccessを削除してもリダイレクトは効いていて404エラーになります。ローカルにログインフォームを作ってもリダイレクトしてダメでした。強制的にログインできる方法はないでしょうか??これまでずっと管理者でログイン状態だったのでこの問題に気がつきませんでした。ブロックが違うのか、ゲスト権限に問題があるのか分かりませんが、困っています・・・よろしくお願いいたします。.htaccessの内容↓-----RewriteEngine onRewriteCond %{REQUEST_FILENAME} !-fRewriteCond %{REQUEST_FILENAME} !-dRewriteRule ^(.+)$ modules/Plugg/index.php?q=/$1 [E=REQUEST_URI:/modules/Plugg/index.php?q=/$1,L,QSA]-----環境↓XOOPS Cube Legacy(JP2.0からアップ)php 5.2.8、MySQL 4系 突然管理画面にログインできなくなりました・・・
http://サイトアドレス/user/login?return=1
http://サイトアドレス/user/register
などにアクセスすると500エラーになります。

Plugg導入済のため、
http://サイトアドレス/user.phpや
http://サイトアドレス/admin.phpに
アクセスしても
http://サイトアドレス/user/login
にリダイレクトされてしまいます。

Pluggのプラグインのxiggや
プロフページなどにはアクセスできます。
http://サイトアドレス/xigg/1
http://サイトアドレス/user/1

Pluggの設定でmod_rewriteを有効にしていました。
対応する.htaccessも設置しています。
もちろんサーバのmod_rewriteは有効です。

.htaccessを削除してもリダイレクトは
効いていて404エラーになります。
ローカルにログインフォームを作っても
リダイレクトしてダメでした。

強制的にログインできる方法はないでしょうか??

これまでずっと管理者でログイン状態だったので
この問題に気がつきませんでした。
ブロックが違うのか、ゲスト権限に問題が
あるのか分かりませんが、困っています・・・

よろしくお願いいたします。

.htaccessの内容↓
-----
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ modules/Plugg/index.php?q=/$1 [E=REQUEST_URI:/modules/Plugg/index.php?q=/$1,L,QSA]
-----
環境↓
XOOPS Cube Legacy(JP2.0からアップ)
php 5.2.8、MySQL 4系]]>
lemon-s 2010-05-03T02:54+09:00 XCL2.1.7