XOOPS Cube日本サイト (XCL2.1.8) http://xoopscube.jp/forum?category_id=30&keyword= 最新公開記事 session.cookie_secure をオンにするとログインできない http://xoopscube.jp/forum/7247 XOOPS Cube Legacy 2.1.8でポータルサイトを運営していますが、php.iniでsession.cookie_secure=1にするとログインできなくなります。session.cookie_secure=1でxoopsが上手く稼働できている方、是非回避策をご教示下さい。

XOOPS Cube Legacy 2.1.8でポータルサイトを運営していますが、php.iniでsession.cookie_secure=1にするとログインできなくなります。
session.cookie_secure=1でxoopsが上手く稼働できている方、是非回避策をご教示下さい。

]]>
chibayan 2015-11-06T10:04+09:00 XCL2.1.8
プロフィールの編集、項目追加をしたい http://xoopscube.jp/forum/6848 はじめまして。XCL2.1.8を使用しています。登録ユーザーのプロフィールの内容を変更したり項目を追加したりしたいと考えております。profileモジュールを使用するのかと思い使ってみたのですがいまひとつ良くわかりません。このモジュールに関するドキュメントも具体的な使用法などはなかなか見当たりませんでした。こちらのサイトでもプロフィール内容がカスタマイズされているようですが、なにかモジュールを使用しているのでしょうか。アドバイスいただけると助かります。どうぞよろしくお願いいたします。 はじめまして。
XCL2.1.8を使用しています。
登録ユーザーのプロフィールの内容を変更したり項目を追加したりしたいと考えております。
profileモジュールを使用するのかと思い使ってみたのですがいまひとつ良くわかりません。
このモジュールに関するドキュメントも具体的な使用法などはなかなか見当たりませんでした。
こちらのサイトでもプロフィール内容がカスタマイズされているようですが、
なにかモジュールを使用しているのでしょうか。
アドバイスいただけると助かります。
どうぞよろしくお願いいたします。]]>
ginga55 2011-05-27T13:03+09:00 XCL2.1.8
正常にインストールされない http://xoopscube.jp/forum/7137 はじめまして、xoopsのインストールにはまっています。xoops2.1.8の第2インストールを実行するとWarning [Xoops]: Smarty error: unable to read resource: "db:system_redirect.html" in file xoopspath\smarty\Smarty.class.php line 1092のエラーが発生します。どなたかご存じのかたがいたらご指導よろしくお願いいたします。※第1インストールは、正常にインストールされます。環境は、下記の通りですWINDOWS SERVER 2008(32bit)PHP:PHP5.2MYSQL:MYSQL5.5Tomcat はじめまして、xoopsのインストールにはまっています。

xoops2.1.8の第2インストールを実行すると

Warning [Xoops]: Smarty error: unable to read resource: "db:system_redirect.html" in file
xoopspath\smarty\Smarty.class.php line 1092

のエラーが発生します。どなたかご存じのかたがいたらご指導よろしくお願いいたします。
※第1インストールは、正常にインストールされます。

環境は、下記の通りです
WINDOWS SERVER 2008(32bit)
PHP:PHP5.2
MYSQL:MYSQL5.5
Tomcat]]>
0821 2013-06-28T23:22+09:00 XCL2.1.8
x_movie swfファイルを再生途中で動画が止まってしまい,最後まで再生されない http://xoopscube.jp/forum/7063 xoops初心者です。x_movieでswfを再生している途中,10分〜30分ほどで止まってしまい,もう一回再生ボタンを押すとまた最初から再生されるという症状が相次いでいます。swfがどういうものか詳しくわからないのですが,同じディレクトリに同じ名前のswfとflvをサーバーにアップして,x_movieの動画登録の画面ではswfを指定して再生するようにしています。今までこれでなんの問題もなく1年以上運用できていましたが,つい先日から途中で止まるようになりました。さらに深い事情をはなすと,実はx_movieだけではなく,HPにそもそもの異常が現れたのがpicocalのモジュールが入っているトップページがhttp500のエラーによって表示されなくなったところからでした。そのトップページは表示されないけど,それ以外のページは開きます。なので対症療法的にトップページをx_movieの動画ページに変えて運用しようとしていました。原因を探ろうと思っていろいろしらべたんですが,アクセスログなどのとり方が分からず,とりあえず,どこかのphpの記述にエラーがあるのかと思い,picocalとpicoのモジュールをバックアップとって新しくダウンロードしたものをもう一度アップロードしなおしました。が,結局直らないでいます。もしかしたらそのあたりで何かミスをしている可能性もあるのかもしれません。直面している問題としては1.x_movieで再生中の動画がとまる。(2.picocalのページがhttp500内部サーバーエラーで表示されない)1の方が急務で何とかしたいと思っています。ちなみにxcl 2.1.8です。前任者が組んだHPの管理をしていて,今急いで勉強中です。初心者ですがよろしくおねがいします. xoops初心者です。
x_movieでswfを再生している途中,10分〜30分ほどで止まってしまい,もう一回再生ボタンを押すとまた最初から再生されるという症状が相次いでいます。swfがどういうものか詳しくわからないのですが,同じディレクトリに同じ名前のswfとflvをサーバーにアップして,x_movieの動画登録の画面ではswfを指定して再生するようにしています。

今までこれでなんの問題もなく1年以上運用できていましたが,つい先日から途中で止まるようになりました。

さらに深い事情をはなすと,実はx_movieだけではなく,HPにそもそもの異常が現れたのがpicocalのモジュールが入っているトップページがhttp500のエラーによって表示されなくなったところからでした。そのトップページは表示されないけど,それ以外のページは開きます。なので対症療法的にトップページをx_movieの動画ページに変えて運用しようとしていました。

原因を探ろうと思っていろいろしらべたんですが,アクセスログなどのとり方が分からず,とりあえず,どこかのphpの記述にエラーがあるのかと思い,picocalとpicoのモジュールをバックアップとって新しくダウンロードしたものをもう一度アップロードしなおしました。が,結局直らないでいます。

もしかしたらそのあたりで何かミスをしている可能性もあるのかもしれません。

直面している問題としては
1.x_movieで再生中の動画がとまる。
(2.picocalのページがhttp500内部サーバーエラーで表示されない)

1の方が急務で何とかしたいと思っています。

ちなみにxcl 2.1.8です。
前任者が組んだHPの管理をしていて,今急いで勉強中です。
初心者ですがよろしくおねがいします.]]>
shoheitora 2012-10-22T17:25+09:00 XCL2.1.8
送信メールのエンコーディングをutf-8に変えたい http://xoopscube.jp/forum/6992 XCL2.1.8(hoda塾ディストリビューション)を使用しているのですが、日本語と中国語の混ざったメールを送信すると、メールの題目、本文ともに日本語だけが表示されて中国語が表示されません。メールのヘッダーを見ると以下のようになっています。Content-Transfer-Encoding: 7bitContent-Type: text/plain; charset="iso-2022-jp"送信されるメールのヘッダーを8bit、utf-8にするにはどうすればいいのでしょうか。ちなみにウェブサイト自体はutf-8で問題なく多言語化されています。よろしくおねがいします。 XCL2.1.8(hoda塾ディストリビューション)を使用しているのですが、日本語と中国語の混ざったメールを送信すると、
メールの題目、本文ともに日本語だけが表示されて中国語が表示されません。
メールのヘッダーを見ると以下のようになっています。
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset="iso-2022-jp"

送信されるメールのヘッダーを8bit、utf-8にするにはどうすればいいのでしょうか。
ちなみにウェブサイト自体はutf-8で問題なく多言語化されています。
よろしくおねがいします。]]>
Yoshi2006 2012-02-29T16:19+09:00 XCL2.1.8
d3imgtagの投稿画面での送信時エラー http://xoopscube.jp/forum/6983 分かる方がいましたら教えてください。投稿画面にて、入力項目や画像を設定した後、送信ボタンを押すと、Web サイト側でページを表示できませんといったHTTP500 内部サーバーエラーとなってしまいます。実際に、fullフォルダ内に画像が取り込まれているようですが、thumbsフォルダに何も入っていないため、ブラウザでは登録されているようには見えるが写真が見れないと言った状態です。解決方法が分かる方がいましたら、教えてください。よろしくお願いいたします。 分かる方がいましたら教えてください。

投稿画面にて、入力項目や画像を設定した後、送信ボタンを押すと、

Web サイト側でページを表示できません
といったHTTP500 内部サーバーエラーとなってしまいます。

実際に、fullフォルダ内に画像が取り込まれているようですが、
thumbsフォルダに何も入っていないため、
ブラウザでは登録されているようには見えるが写真が見れないと言った状態です。

解決方法が分かる方がいましたら、教えてください。
よろしくお願いいたします。]]>
teppy 2012-02-16T12:38+09:00 XCL2.1.8
ユーザーメニューの「受信箱」表示をユーザーグループIDで表示/非表示切替したい http://xoopscube.jp/forum/6942 おせわになっております。掲題の件で、ユーザーグループごとにPMの利用権限を変えたいのですが、ブロック権限でそれができないため、ユーザーメニューの「受信箱」表示を表示したり消したりすることでコントロールしようとしています。legacy_block_usermenu.htmlの以下のコードの縦線の部分をIF文で分岐させればいいと思うのですが、分岐条件であるユーザーグループIDをどうやって引っ張ってくるかわかりません。どなたか教えてもらえないでしょうか。ちなみに、グループID=2(登録ユーザー)の時は非表示、その他のグループIDの時は表示としたいです。よろしくおねがいします。<table cellspacing="0"> <tr> <td id="usermenu"> <a class="menuTop" href="<{$xoops_url}>/user.php"><{$smarty.const._MB_LEGACY_VACNT}></a> <a href="<{$xoops_url}>/edituser.php"><{$smarty.const._MB_LEGACY_EACNT}></a> <a href="<{$xoops_url}>/notifications.php"><{$smarty.const._MB_LEGACY_NOTIF}></a> <a href="<{$xoops_url}>/user.php?op=logout"><{$smarty.const._MB_LEGACY_LOUT}></a>| <{if $block.flagShowInbox}>| <{if $block.new_messages > 0}>| <a class="highlight" href="<{$block.inbox_url}>"><{$smarty.const._MB_LEGACY_INBOX}> |(<span style="color:#ff0000; font-weight: bold;"><{$block.new_messages}></span>)</a>| <{else}>| <a href="<{$block.inbox_url}>"><{$smarty.const._MB_LEGACY_INBOX}></a>| <{/if}>| <{/if}> <{if $block.show_adminlink}> <a href="<{$xoops_url}>/admin.php"><{$smarty.const._MB_LEGACY_ADMENU}></a> <{/if}> </td> </tr></table> おせわになっております。
掲題の件で、ユーザーグループごとにPMの利用権限を変えたいのですが、ブロック権限でそれができないため、ユーザーメニューの「受信箱」表示を表示したり消したりすることでコントロールしようとしています。

legacy_block_usermenu.htmlの以下のコードの縦線の部分をIF文で分岐させればいいと思うのですが、分岐条件であるユーザーグループIDをどうやって引っ張ってくるかわかりません。どなたか教えてもらえないでしょうか。
ちなみに、グループID=2(登録ユーザー)の時は非表示、その他のグループIDの時は表示としたいです。
よろしくおねがいします。


<table cellspacing="0">
<tr>
<td id="usermenu">
<a class="menuTop" href="<{$xoops_url}>/user.php"><{$smarty.const._MB_LEGACY_VACNT}></a>
<a href="<{$xoops_url}>/edituser.php"><{$smarty.const._MB_LEGACY_EACNT}></a>
<a href="<{$xoops_url}>/notifications.php"><{$smarty.const._MB_LEGACY_NOTIF}></a>
<a href="<{$xoops_url}>/user.php?op=logout"><{$smarty.const._MB_LEGACY_LOUT}></a>
| <{if $block.flagShowInbox}>
| <{if $block.new_messages > 0}>
| <a class="highlight" href="<{$block.inbox_url}>"><{$smarty.const._MB_LEGACY_INBOX}> |(<span style="color:#ff0000; font-weight: bold;"><{$block.new_messages}></span>)</a>
| <{else}>
| <a href="<{$block.inbox_url}>"><{$smarty.const._MB_LEGACY_INBOX}></a>
| <{/if}>
| <{/if}>
<{if $block.show_adminlink}>
<a href="<{$xoops_url}>/admin.php"><{$smarty.const._MB_LEGACY_ADMENU}></a>
<{/if}>
</td>
</tr>
</table>]]>
Yoshi2006 2012-01-06T15:51+09:00 XCL2.1.8
バックアップが出来ません。 http://xoopscube.jp/forum/6943 「Protector」の「PREFIX」でバックアップを取ろうとしたらエラーが出ました。試しに「MyX_BackUp」でも試したけどこれもダメでした。XOOPS Cube Legacy 2.1.8MySQL 4.1.20PHP Version 5.0.4使用しているOSはWindows7です。ブラウザはIE9では「Internet Explorer cannot display the webpage」FIREFOX9.01では「接続がリセットされました。ページの読み込み中にサーバへの接続がリセットされました。」Chromeでは「データを受信して??いませんサーバーからデータが送信されないためウェブページを読み込むことができません。」と表示されます。ちなみにURLは「https」とSSLが掛かっております。SSLが掛かっていない同じ条件のサーバーで試したところバックアップが取れました。やはりSSLが原因なのでしょうか。よろしくご指導願います。 「Protector」の「PREFIX」でバックアップを取ろうとしたらエラーが出ました。
試しに「MyX_BackUp」でも試したけどこれもダメでした。


XOOPS Cube Legacy 2.1.8
MySQL 4.1.20
PHP Version 5.0.4
使用しているOSはWindows7です。

ブラウザは
IE9では「Internet Explorer cannot display the webpage」
FIREFOX9.01では「接続がリセットされました。ページの読み込み中にサーバへの接続がリセットされました。」
Chromeでは「データを受信して??いませんサーバーからデータが送信されないためウェブページを読み込むことができません。」
と表示されます。

ちなみにURLは「https」とSSLが掛かっております。

SSLが掛かっていない同じ条件のサーバーで試したところバックアップが取れました。
やはりSSLが原因なのでしょうか。

よろしくご指導願います。]]>
take_take 2012-01-06T16:21+09:00 XCL2.1.8
ユーザーモジュール管理権限について http://xoopscube.jp/forum/6914 こんにちは。XCL2.1.8を使用中です。管理人が複数いるサイトを運営しておりまして管理人のグループ分けを行い権限を分けているのですがメール送信(全ユーザへ送信するメルマガのような)だけを行う担当者に「メールジョブ管理」だけの管理権限を与えたいのですが、XCLは「ユーザーモジュール」に対して管理権限を与えないと「メールジョブ管理」が扱えないようになっているのですが、他の権限(ユーザー管理やグループ管理権限等)は与えずにここの権限を分けたいのですが、可能でしょうか?方法をご存じの方、いらっしゃいましたらご教示下さい。または、XCLで使えるメール送信モジュールは存在しますでしょうか?メルマガ送信モジュールなど(検索してもヒットせず…。メールジョブがありますもんね…)もしあればモジュール管理で権限を分けられると思いまして。ご存知の方いらっしゃいましたらご教示下さい。よろしくお願いいたします。 こんにちは。
XCL2.1.8を使用中です。
管理人が複数いるサイトを運営しておりまして
管理人のグループ分けを行い権限を分けているのですが
メール送信(全ユーザへ送信するメルマガのような)だけを行う担当者に
「メールジョブ管理」だけの管理権限を与えたいのですが、
XCLは「ユーザーモジュール」に対して管理権限を与えないと
「メールジョブ管理」が扱えないようになっているのですが、
他の権限(ユーザー管理やグループ管理権限等)は与えずに
ここの権限を分けたいのですが、可能でしょうか?
方法をご存じの方、いらっしゃいましたらご教示下さい。

または、
XCLで使えるメール送信モジュールは存在しますでしょうか?
メルマガ送信モジュールなど
(検索してもヒットせず…。メールジョブがありますもんね…)
もしあれば
モジュール管理で権限を分けられると思いまして。
ご存知の方いらっしゃいましたらご教示下さい。

よろしくお願いいたします。]]>
hiroko100 2011-11-16T10:57+09:00 XCL2.1.8
myAdsのコメント、投稿画面編集についてのご質問 http://xoopscube.jp/forum/6852 はじめまして、xoops勉強中です。XCL2.1.8、MyAds2.05を使用させて頂いております。(英語表記になる為、ja_utf8で変更しています)myAdsに関して2点質問させて下さいませ。1.コメント機能が動かない「コメント投稿に関するルール」で「証人は必要ない」にしていますがコメント投稿そのものが表示されない状態です2.myAdsの投稿画面で「市区町村 :」の削除を行おうとしておりますがテンプレート部分でみつけられず、変更方法を探しています検索してみたのですが見つけられず、見落としておりましたらすみません。よろしればお教え下さい。どうぞよろしくお願いします。 はじめまして、xoops勉強中です。
XCL2.1.8、MyAds2.05を使用させて頂いております。
(英語表記になる為、ja_utf8で変更しています)

myAdsに関して2点質問させて下さいませ。

1.コメント機能が動かない
「コメント投稿に関するルール」で「証人は必要ない」にしていますが
コメント投稿そのものが表示されない状態です

2.myAdsの投稿画面で「市区町村 :」の削除を
行おうとしておりますがテンプレート部分でみつけられず、
変更方法を探しています

検索してみたのですが見つけられず、見落としておりましたらすみません。
よろしればお教え下さい。どうぞよろしくお願いします。]]>
hasuike 2011-06-16T18:05+09:00 XCL2.1.8
functions.phpの変更が反映されない http://xoopscube.jp/forum/6795 ユーザー登録時に、登録できるメールアドレスのドメインを制限するために、/include/functions.phpのcheckEmail関数の定義を以下のように変更しました。しかし、ログアウトして新規登録するときに、別のドメインでも登録できてしまいます。checkEmailが全く効いていないのではと思い、メールアドレスを「abc」にしてみますと、ちゃんと「不正なメールアドレスです」とはじいてくれますが、自分のgmail等のアドレスを入力すると、あっさり登録できてしまいます。原因がわかりません。よろしくお願い致します。登録できるドメイン:test.test.xoops.ac.jp/include/functions.phpの変更した場所:if (!function_exists(&quot;checkEmail&quot;)) {function checkEmail($email,$antispam = false){ if (!$email || !preg_match(&quot;/^[_a-z0-9-]+(\.[_a-z0-9-]+)*@test.test.xoops.ac.jp+$/i&quot;,$email)){ return false; } if ($antispam) { $email = str_replace(&quot;@&quot;, &quot; at &quot;, $email); $email = str_replace(&quot;.&quot;, &quot; dot &quot;, $email); return $email; } else { return true; }}} ユーザー登録時に、登録できるメールアドレスのドメインを制限するために、
/include/functions.phpのcheckEmail関数の定義を以下のように変更しました。
しかし、ログアウトして新規登録するときに、別のドメインでも登録できてしまいます。
checkEmailが全く効いていないのではと思い、メールアドレスを「abc」にしてみますと、ちゃんと「不正なメールアドレスです」とはじいてくれますが、自分のgmail等のアドレスを入力すると、あっさり登録できてしまいます。

原因がわかりません。よろしくお願い致します。

登録できるドメイン:test.test.xoops.ac.jp

/include/functions.phpの変更した場所:

if (!function_exists("checkEmail")) {
function checkEmail($email,$antispam = false)
{
if (!$email || !preg_match("/^[_a-z0-9-]+(\.[_a-z0-9-]+)*@test.test.xoops.ac.jp+$/i",$email)){
return false;
}
if ($antispam) {
$email = str_replace("@", " at ", $email);
$email = str_replace(".", " dot ", $email);
return $email;
} else {
return true;
}
}
}]]>
nkgvl 2010-11-19T01:39+09:00 XCL2.1.8
ページ下部のエラー表示について http://xoopscube.jp/forum/6811 XCL2.1.8をインストールしてテーマをfct_offlimitsにしました。トップページ以下全てに以下のようなメッセージが出ます。どのようなエラーなのでしょうか。これを無くすにはどうしたらよいでしょうか。宜しくお願いいたします。Warning [PHP]: fopen(/cache/theme_fct_offlimits_menus_2e31.php) [function.fopen]: failed to open stream: No such file or directory in file themes/fct_offlimits/hd_assign.php line 203 XCL2.1.8をインストールしてテーマをfct_offlimitsにしました。
トップページ以下全てに以下のようなメッセージが出ます。
どのようなエラーなのでしょうか。
これを無くすにはどうしたらよいでしょうか。
宜しくお願いいたします。

Warning [PHP]: fopen(/cache/theme_fct_offlimits_menus_2e31.php) [function.fopen]: failed to open stream: No such file or directory in file themes/fct_offlimits/hd_assign.php line 203]]>
paff 2011-01-12T13:16+09:00 XCL2.1.8
インストールができません。どなたかご指導を http://xoopscube.jp/forum/6835 Xoops初心者です。以下の環境でインストールができずに困っております。よろしくご指導お願いします   環境OS: SUSE Linux Enterprise Server 11Web Server : Apache ver 2.0DB : MySQL ver 5.0Xoops Legascy 2.1.08a   状況1. ダウンロードしたZoops LegacyのZip を解凍し、htmlフォルダーのみをWebxサーバー上にコピーいたしました。2. インストール画面から始めて、「データベース設定の確認」の画面で内容を確認したのち、次へ進むと、真っ白の画面が表示されてしまいます。 MySQLを確認してみると、あらかじめ作成しておいた空のデータベース&#039;xoopsdb&#039; にはテーブルが全く作成されておりません。  データベースユーザー名を所有者や &#039;root&#039; に変更して幾度かインストールを試みましたが結果は変わりませんでした。以上のような状況です。よろしくお願いいたします Xoops初心者です。以下の環境でインストールができずに困っております。よろしくご指導お願いします

   環境

OS: SUSE Linux Enterprise Server 11
Web Server : Apache ver 2.0
DB : MySQL ver 5.0
Xoops Legascy 2.1.08a


   状況

1. ダウンロードしたZoops LegacyのZip を解凍し、htmlフォルダーのみをWebxサーバー上にコピーいたしました。
2. インストール画面から始めて、「データベース設定の確認」の画面で内容を確認したのち、次へ進むと、真っ白の画面が表示されてしまいます。

 MySQLを確認してみると、あらかじめ作成しておいた空のデータベース'xoopsdb' にはテーブルが全く作成されておりません。
 データベースユーザー名を所有者や 'root' に変更して幾度かインストールを試みましたが結果は変わりませんでした。

以上のような状況です。よろしくお願いいたします]]>
mshirai 2011-05-08T10:19+09:00 XCL2.1.8
イベントモジュールeguideの複製について http://xoopscube.jp/forum/6865 XOOPS Cube Legacy 2.1.8でイベントモジュールのeguideを使っています。同じサイト内に、モジュールを2つ設置したく、ALTSYSのブロック管理から「強制複製」を行いました。ところが、イベント登録やイベント削除などをすると2つとものモジュールに反映されてしまいます。モジュールの機能だけ複製して、イベントの内容などは、まったく別のものを載せたいのですがどうゆう風に使ったらいいのでしょうか?どなたかアドバイスお願いいたします。 XOOPS Cube Legacy 2.1.8でイベントモジュールのeguideを使っています。

同じサイト内に、モジュールを2つ設置したく、
ALTSYSのブロック管理から「強制複製」を行いました。

ところが、イベント登録やイベント削除などをすると2つとものモジュールに反映されてしまいます。

モジュールの機能だけ複製して、イベントの内容などは、まったく別のものを載せたいのですが
どうゆう風に使ったらいいのでしょうか?

どなたかアドバイスお願いいたします。]]>
milishank 2011-07-27T18:42+09:00 XCL2.1.8
xwords モジュール名を変更した際のd3pipesへのRSS取得 http://xoopscube.jp/forum/6875 XOOPS Cube Legacy 2.1.d3pipes 0.68 (リネーム済み)xwords 0.46  (リネーム済み 仮に 「zwords」とします)確か以前のバージョンには入っていたと思うのですがd3pipes 0.68には何故かXWORDSのジョイントが入っていなかったのでモーションクリエイト様のXWORDS用 d3pipesジョイントクラスを使用させていただいています。リネームしていない物で試した所問題なかったのですが何かのバージョンが異なるのかリネームした物に関してはd3pipesのサイト内新着情報パイプ作成ウイザードでチェックを入れれません。一度別のもので作ってから編集するとxwordlistが出てくるのですが設定しても「ブロック関数ジョイントで関数名指定にミスがありますxwords_b_entries_new_show (D3pipesBlockXwordslist)」とエラーが表示されます。これはD3pipesBlockXwordslist.class.php の中のxwords_b_entries_new_show 部分のxwordsをリネームしたzwordsにしてもだめでしょうか?試してみたのですがただ何処かが抜けていたのかやり方が間違っているのかうまくいきません。教えていただけないでしょうか? XOOPS Cube Legacy 2.1.
d3pipes 0.68 (リネーム済み)
xwords 0.46  (リネーム済み 仮に 「zwords」とします)


確か以前のバージョンには入っていたと思うのですが
d3pipes 0.68には何故かXWORDSのジョイントが入っていなかったので

モーションクリエイト様の
XWORDS用 d3pipesジョイントクラス

を使用させていただいています。


リネームしていない物で試した所問題なかったのですが
何かのバージョンが異なるのか

リネームした物に関しては
d3pipesのサイト内新着情報パイプ作成ウイザード
でチェックを入れれません。

一度別のもので作ってから編集すると
xwordlistが出てくるのですが

設定しても
「ブロック関数ジョイントで関数名指定にミスがあります
xwords_b_entries_new_show (D3pipesBlockXwordslist)」

とエラーが表示されます。

これは
D3pipesBlockXwordslist.class.php の中の
xwords_b_entries_new_show 部分のxwordsを
リネームしたzwordsにしてもだめでしょうか?

試してみたのですがただ何処かが抜けていたのか
やり方が間違っているのかうまくいきません。


教えていただけないでしょうか?]]>
ni48 2011-08-12T22:50+09:00 XCL2.1.8
XoopsFormを使わないフォームに置き換えたい http://xoopscube.jp/forum/6881 はじめまして、プログラミングの知識がほとんどないのに無謀にもモジュールのカスタマイズをしたいと思っています。gnaviやSearch204といったモジュールの入力フォームsubmit.phpやsearchform.phpの見栄えを変えたり、jQueryを盛り込んだりしたいのですが、XOOPSFORMというのが使われていてどうにも自由に編集できそうにありません。検索したり調べていた感じからするとXOOPSFORM使わなければいいんじゃない?ってことだと思うのですが、プログラミングのスキルが乏しくて何をどうすれば良いのかわかりません。XoopsFormではこう書いているところをこう書けば良い等と具体的な例を頂けると幸いです。どうかご教授下さい。 はじめまして、プログラミングの知識がほとんどないのに無謀にも
モジュールのカスタマイズをしたいと思っています。

gnaviやSearch204といったモジュールの入力フォームsubmit.phpやsearchform.php
の見栄えを変えたり、jQueryを盛り込んだりしたいのですが、XOOPSFORMというのが使われていて
どうにも自由に編集できそうにありません。

検索したり調べていた感じからするとXOOPSFORM使わなければいいんじゃない?
ってことだと思うのですが、プログラミングのスキルが乏しくて何をどうすれば良いのかわかりません。
XoopsFormではこう書いているところをこう書けば良い等と具体的な例を頂けると幸いです。

どうかご教授下さい。]]>
yuwyeni 2011-09-06T14:08+09:00 XCL2.1.8
weblinksの概要表示で顔アイコンが表示されない http://xoopscube.jp/forum/6837 こんにちは。weblinksを使っていてふと気がついたのですが、顔アイコンを使用して新規リンクを投稿し、それが新着情報としてweblinksのTopページに一覧で表示される際に、顔アイコンが表示されません(文字は表示されます)。概要表示では、顔アイコンの部分は半角の空白になっていて、表示されたもののソースを見ても、半角の空白です。以前にもスマイリーアイコンが表示されないというのはあったみたいですが、http://linux.ohwada.jp/modules/newbb/viewtopic.php?viewmode=thread&amp;topic_id=746&amp;forum=5バージョンもだいぶ上がっているし、こちらはアイコンの画像が、バツ印で表示されないとゆうことなのでちょっと状況がちがうのかなと思っています。私がウッカリしているだけで、概要表示に顔アイコンを表示する方法がデフォルトであるのかもしれませんが、どなたかご教授いただけますでしょうか。宜しくお願いします。xoopscube2.1.8aHappy Linux1.50 wevlinks1.95 ALTSYS0.71 こんにちは。
weblinksを使っていてふと気がついたのですが、
顔アイコンを使用して新規リンクを投稿し、それが新着情報としてweblinksのTopページに一覧で表示される際に、
顔アイコンが表示されません(文字は表示されます)。

概要表示では、顔アイコンの部分は半角の空白になっていて、
表示されたもののソースを見ても、半角の空白です。

以前にもスマイリーアイコンが表示されないというのはあったみたいですが、
http://linux.ohwada.jp/modules/newbb/viewtopic.php?viewmode=thread&topic_id=746&forum=5
バージョンもだいぶ上がっているし、
こちらはアイコンの画像が、バツ印で表示されないとゆうことなので
ちょっと状況がちがうのかなと思っています。

私がウッカリしているだけで、概要表示に顔アイコンを表示する方法がデフォルトであるのかもしれませんが、
どなたかご教授いただけますでしょうか。宜しくお願いします。

xoopscube2.1.8a
Happy Linux1.50
wevlinks1.95
ALTSYS0.71]]>
megajyo 2011-05-10T13:05+09:00 XCL2.1.8
moduleのインストールについて http://xoopscube.jp/forum/6850 当方のローカル環境はXampp1.7.1 Xoops2.1.8でwindows7で稼動させています。モジュールをサイトからダウンロードして、規定のフォルダに入れるのですが、xoopsのモジュールインストール画面には表示(反映)されません。Pathは確認しましたが。。その後は何を試せばよいのかわかりません。どなたかアドバイスいただければ助かります。 当方のローカル環境はXampp1.7.1 Xoops2.1.8でwindows7で稼動させています。

モジュールをサイトからダウンロードして、規定のフォルダに入れるのですが、xoopsのモジュールインストール
画面には表示(反映)されません。Pathは確認しましたが。。その後は何を試せばよいのかわかりません。

どなたかアドバイスいただければ助かります。]]>
studiosai 2011-06-02T10:16+09:00 XCL2.1.8
イメージマネージャーでの文字化け http://xoopscube.jp/forum/6839 XoopsでSNS風のコミュニティサイトを構築しようとしております。CentOS 5.2Mysql 5.0.45XCL2.1.8aweblogD3_1.5.3.4の環境で使用しているのですが、WeblogD3で画像投稿する際のイメージマネージャーが文字化けしております。イメージマネージャーだけがUTF8と誤認識されているようです。IEの右クリックメニューからエンコードを手動設定すると正しく表示されます。FireFOXでのブラウズも試しましたが、同様の結果でした。原因や、確認すべき点があればご指摘頂けますでしょうか。よろしくお願い致します。 XoopsでSNS風のコミュニティサイトを構築しようとしております。
CentOS 5.2
Mysql 5.0.45
XCL2.1.8a
weblogD3_1.5.3.4
の環境で使用しているのですが、WeblogD3で画像投稿する際のイメージマネージャーが
文字化けしております。
イメージマネージャーだけがUTF8と誤認識されているようです。
IEの右クリックメニューからエンコードを手動設定すると正しく表示されます。

FireFOXでのブラウズも試しましたが、同様の結果でした。

原因や、確認すべき点があればご指摘頂けますでしょうか。
よろしくお願い致します。]]>
katsuwo7 2011-05-18T22:40+09:00 XCL2.1.8
インストールエラー http://xoopscube.jp/forum/6840 インストールを進めるステップでブラウザにStrict Standards:... Depuricated..のレポートが表示されます。何か良い対処方はないでしょうか?PHP.iniで;error_reporting = E_ALL | E_STRICTをerror_reporting = E_ALLに変更してみましたが変化はありません。よろしくお願いします。 インストールを進めるステップでブラウザにStrict Standards:... Depuricated..のレポートが表示されます。何か良い対処方はないでしょうか?

PHP.iniで;error_reporting = E_ALL | E_STRICTを
error_reporting = E_ALLに変更してみましたが変化はありません。

よろしくお願いします。]]>
2011-05-19T00:28+09:00 XCL2.1.8