ホーム > フォーラム > 質問箱 > XCL2.2 > Cube2.2でFCKeditorが使えません。

Cube2.2でFCKeditorが使えません。
投稿者: p506007yj | 投稿日時: 2012/2/11 11:00 | 閲覧: 16500回
p506007yj

vaule-domeinのレンタルサーバーを利用しており、XOOPSのインストールが無事完了し、D3モジュールも無事に入れることができ、さあ、ホームページの構築だ、という所でトラブル発生です。(Cube2.2です。)
 タイトル通り、FCKeditorが使えない状況になっています。
 pico(HD-1.79)等でコンテンツの編集をするのですが、xoopshtmlとほとんど変わらない状態であります(picoの一般設定で変更は試みています。)。
 入力支援のON/OFFは切り替わっているので、javascriptが原因ではなさそうです。
 xoopshtmlで「fckeditor」のボタンを押すと、「表題を入力してください。」と指示が出ます。指示通り入力して「fckeditor」ボタンを押すと、あっけらかんとした画面が出て終わりです(picoの一般設定でcommon/fckeditorに設定しても同様の現象です。)。
 メインブラウザはグーグルクロームであり、IE8でも接続しましたが、改善の兆しは見られません(OSはXP)。
 フォルダの保存はサーバーの最上層に「XOOPS_ROOT_PATH」を作成し、その下に「common」フォルダをアップロードしたり、サーバーの最上層の場所に同様に「common」フォルダをアップロードしてもダメでした。
 何か思い当たる原因があればご教授願いたいと思います(必要であれば追記もします。)。
 FCKeditorのバージョンは2.5.1-003です。
 同様の質問は検索でいくつかあったのですが、どれも解決には結びつきませんでした。

コメント(4)

新しいものから | 古いものから | ネスト表示 | RSS feed
Re: Cube2.2でFCKeditorが使えません。 
投稿者: p506007yj | 投稿日時: 2012/2/11 15:50
p506007yj
引用:
vaule-domeinのレンタルサーバーを利用しており、XOOPSのインストールが無事完了し、D3モジュールも無事に入れることができ、さあ、ホームページの構築だ、という所でトラブル発生です。(Cube2.2です。)
 タイトル通り、FCKeditorが使えない状況になっています。
 pico(HD-1.79)等でコンテンツの編集をするのですが、xoopshtmlとほとんど変わらない状態であります(picoの一般設定で変更は試みています。)。
 入力支援のON/OFFは切り替わっているので、javascriptが原因ではなさそうです。
 xoopshtmlで「fckeditor」のボタンを押すと、「表題を入力してください。」と指示が出ます。指示通り入力して「fckeditor」ボタンを押すと、あっけらかんとした画面が出て終わりです(picoの一般設定でcommon/fckeditorに設定しても同様の現象です。)。
 メインブラウザはグーグルクロームであり、IE8でも接続しましたが、改善の兆しは見られません(OSはXP)。
 フォルダの保存はサーバーの最上層に「XOOPS_ROOT_PATH」を作成し、その下に「common」フォルダをアップロードしたり、サーバーの最上層の場所に同様に「common」フォルダをアップロードしてもダメでした。
 何か思い当たる原因があればご教授願いたいと思います(必要であれば追記もします。)。
 FCKeditorのバージョンは2.5.1-003です。
 同様の質問は検索でいくつかあったのですが、どれも解決には結びつきませんでした。


 テーマの表示が何か関係されているようです(固定化すると使えるようになる?)。固定化の方法は不明です。今のテーマも気に入っているのですが、モジュール(というか機能)が使えないと意味が無いと思うので、違うテーマに変えようと思います。ただ、回答は依然受付中とします
Re: Cube2.2でFCKeditorが使えません。 
投稿者: marine | 投稿日時: 2012/2/14 23:32 | 親コメント: #21020
marine
引用:
 テーマの表示が何か関係されているようです(固定化すると使えるようになる?)。固定化の方法は不明です。


「固定化」というのが、何のことを指されているのか、全く理解できませんが・・・
もし、現在使っているテーマでFCKeditorが使えず、他のテーマで使えるということなら、現在使っているテーマの「何か」が原因ということになりますね。

そして、もし現在使っているテーマが、テーマ下テンプレートを使っているのなら、そのテーマ下テンプレートを削除してみてください。
(今回の場合、テーマディレクトリ内にある template の下にある pico ディレクトリということになりますね。)

あと、picoのバージョンとか、FCKeditorのバージョンとかで、上手く動作したりしなかったり・・・
結構色々な要件があるような気もします。

試されるなら、最新のディストリビューションである pack2012 と その中に入っている pico でテストされるのが 吉 だと思います。
pack2012 (pack2011) については、このサイトのトップページのニュース一覧をご覧になるか、下記リンク先をご覧下さい。

http://sourceforge.jp/projects/xoopscube22x/releases/
新たなエラー発生 
投稿者: p506007yj | 投稿日時: 2012/2/18 16:33 | 親コメント: #21025
p506007yj
引用:
引用:
 テーマの表示が何か関係されているようです(固定化すると使えるようになる?)。固定化の方法は不明です。

「固定化」というのが、何のことを指されているのか、全く理解できませんが・・・
もし、現在使っているテーマでFCKeditorが使えず、他のテーマで使えるということなら、現在使っているテーマの「何か」が原因ということになりますね。

そして、もし現在使っているテーマが、テーマ下テンプレートを使っているのなら、そのテーマ下テンプレートを削除してみてください。
(今回の場合、テーマディレクトリ内にある template の下にある pico ディレクトリということになりますね。)

あと、picoのバージョンとか、FCKeditorのバージョンとかで、上手く動作したりしなかったり・・・
結構色々な要件があるような気もします。

試されるなら、最新のディストリビューションである pack2012 と その中に入っている pico でテストされるのが 吉 だと思います。
pack2012 (pack2011) については、このサイトのトップページのニュース一覧をご覧になるか、下記リンク先をご覧下さい。

http://sourceforge.jp/projects/xoopscube22x/releases/


回答ありがとうございました。返信が遅れて申し訳ありません。
「テーマの固定化」についてですが、「表示幅の固定化」ですね。言葉足らずで申し訳ありませんでした。
さっそく、pack2012をレンタルサーバーにアップロードしたのですが、インストール開始時に以下のようなエラーが出て手詰まり状態です。
どなたか、解決法をご教授くださいませ。

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Fatal error: Unknown: Failed opening required '/virtual/ディレクトリ名/public_html/index.php' (include_path='.:/usr/local/lib/php') in Unknown on line 0

どうようなエラーメッセージが出ているかはgoogle等で調べてわかったのですが、この場合の対処法がわからず困惑しております。
自己解決しました。 
投稿者: p506007yj | 投稿日時: 2012/2/19 21:48 | 親コメント: #21028
p506007yj
引用:
引用:
引用:
 テーマの表示が何か関係されているようです(固定化すると使えるようになる?)。固定化の方法は不明です。

「固定化」というのが、何のことを指されているのか、全く理解できませんが・・・
もし、現在使っているテーマでFCKeditorが使えず、他のテーマで使えるということなら、現在使っているテーマの「何か」が原因ということになりますね。

そして、もし現在使っているテーマが、テーマ下テンプレートを使っているのなら、そのテーマ下テンプレートを削除してみてください。
(今回の場合、テーマディレクトリ内にある template の下にある pico ディレクトリということになりますね。)

あと、picoのバージョンとか、FCKeditorのバージョンとかで、上手く動作したりしなかったり・・・
結構色々な要件があるような気もします。

試されるなら、最新のディストリビューションである pack2012 と その中に入っている pico でテストされるのが 吉 だと思います。
pack2012 (pack2011) については、このサイトのトップページのニュース一覧をご覧になるか、下記リンク先をご覧下さい。

http://sourceforge.jp/projects/xoopscube22x/releases/

回答ありがとうございました。返信が遅れて申し訳ありません。
「テーマの固定化」についてですが、「表示幅の固定化」ですね。言葉足らずで申し訳ありませんでした。
さっそく、pack2012をレンタルサーバーにアップロードしたのですが、インストール開始時に以下のようなエラーが出て手詰まり状態です。
どなたか、解決法をご教授くださいませ。

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Fatal error: Unknown: Failed opening required '/virtual/ディレクトリ名/public_html/index.php' (include_path='.:/usr/local/lib/php') in Unknown on line 0

どうようなエラーメッセージが出ているかはgoogle等で調べてわかったのですが、この場合の対処法がわからず困惑しております。


すいません。自己解決しました。
サーバーアップロード時の属性変更が「*php 700」になっていたのが原因でした。
「*php 705」にしたら無事にアップロードできました。
いろいろご協力いただきありがとうございました。
これにて失礼いたします。
FCKeditorも無事に使えることを確認しました。
協力してくださった皆さん、本当にありがとうございました。

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top