ホーム > フォーラム > 質問箱 > XCL2.2(Pack 2012) > "XOOPS Cube ver 2.2"の時間表示バグについて

"XOOPS Cube ver 2.2"の時間表示バグについて
投稿者: maxlien | 投稿日時: 2012/7/10 0:38 | 閲覧: 12094回
maxlien

質問です。

最近「XOOPS Cube ver 2.1.5」から「XOOPS Cube ver 2.2」にアップグレード(別フォルダでインストール)したのですが、
Xoops上で表記される時間がバグり、正常に表示されません。

サーバが原因かと思い、下記のレンタルサーバで試した所同様の不具合が発生します。
これはXCL2.2から発生しています。

通常時間表示について、例えばモジュール管理であれば

「最終更新日」⇒ ****/**/** で表記されるはずが、
「最終更新日」⇒ _TueAMKSTEthKSTR020 と表記されてしまいます。

この問題について、調べても改善策もしくは解決策が見つかりませんでしたので
投稿させて頂きました。

どなたか分りますでしょうか?

コメント(6)

新しいものから | 古いものから | ネスト表示 | RSS feed
Re: "XOOPS Cube ver 2.2"の時間表示バグについて 
投稿者: maxlien | 投稿日時: 2012/7/14 15:58
maxlien

全く回答が無い為、仕方がなくダウングレードしようかと思います。
同様の問題を抱えているのは私だけなのでしょうか・・・。
Re: "XOOPS Cube ver 2.2"の時間表示バグについて 
投稿者: rohi | 投稿日時: 2012/7/14 23:56 | 親コメント: #21101
rohi
引用:
全く回答が無い為、仕方がなくダウングレードしようかと思います。
同様の問題を抱えているのは私だけなのでしょうか・・・。


ローカル環境でXCL2.1.7からXOOPS X(ten)でアップグレードしようとしたところ、同様の事象が発生しました。
まだ試していないので回答にはならないのですが、
http://www.xugj.org/modules/QandA/index.php?topic_id=2095
ではaltsys-0.71eパッチ版を使用することで解決されたようです。
Re: "XOOPS Cube ver 2.2"の時間表示バグについて 
投稿者: nobu | 投稿日時: 2012/7/18 17:33
nobu

症状から見る限り、時間フォーマットを定義する定数 _DATESTRING が未定義になってしまっているようです。(定数名を時間フォーマットとして解釈すると _TueAMKSTEthKSTR020 のような文字列になる)

この定義自体は、legacy モジュールの言語ファイル modules/legacy/language/{japanese,ja_utf8,etc}/settings.php に置かれているものなので、このファイルが正常にアップロードされてないとか、ではないでしょうか。
Re: "XOOPS Cube ver 2.2"の時間表示バグについて 
投稿者: naao | 投稿日時: 2012/7/18 22:24
naao

nobuさんのコメントの補足ですが、

XCL2.2本体配布版では、日本語の言語ファイルはextrasに収録されていますので、 インストールやアップデートの際に、使用言語ファイルを手作業で移動する必要があります。

最新のXOOPS X ディストリビューションでは、utf8もjapanese(EUC-JP)も予め移動済みだったりしますので、参考にしていただければと思います。

もし、これが原因で解決できそうでしたら、「バグ」ではないと思いますのでよろしくです。
Re: "XOOPS Cube ver 2.2"の時間表示バグについて 
投稿者: marine | 投稿日時: 2012/7/18 23:33
marine

私も、ローカル環境で旧サイトのデータをアップデートしていて、同じ症状に見舞われました。そして、問題解消できました。

extra_preload に入っている SetupAltsysLangMgr.class.php をサイトのプリロードディレクトリにアップしてください。

多分、それで解消するはずです。
Re: "XOOPS Cube ver 2.2"の時間表示バグについて 
投稿者: rohi | 投稿日時: 2012/7/22 1:46 | 親コメント: #21106
rohi
引用:
extra_preload に入っている SetupAltsysLangMgr.class.php をサイトのプリロードディレクトリにアップしてください。


私はXOOPS X(ten)でのアップグレードなので disabled から出して上書きしたところ正しく表示されるようになりました。
marineさん、どうもありがとうございました。

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top