ホーム > フォーラム > 質問箱 > XCL2.2 > 「ホーム」が正しく表示されない (真っ白またはエラー)

「ホーム」が正しく表示されない (真っ白またはエラー)
投稿者: tsumosan | 投稿日時: 2013/11/6 10:29 | 閲覧: 9547回
tsumosan

XOOPS Cube Legacy 2.2.2を利用させて頂いております.
(CentOS6.5, Apache/2.2.15, PHP/5.3.3, mysql/5.1.69)

複数人で共同作業しているため,どの作業内容が引き金になったのかは分からないのですが,

http://xxx.xxx.xxx/xoops/

にアクセスした場合に,

・Firefox(25.0)だと画面が真っ白になる
・IE(9, 10)だとHTTP 500エラーが出る

の状況になってしまいます.但し,

http://xxx.xxx.xxx/xoops/user.php

にてログインした場合は問題なく利用でき,ログアウトするまで「ホーム」も正常に
表示されます(ログアウトするとまた異常な状況に逆戻りします).

Apacheはerror_logを全く吐いてくれず,XOOPSの管理者メニューから「PHPデバッグ」を
ONにしても何もエラーメッセージを出さないので,どこを疑ってよいのか全く分かりません.

素人目には,index.php→user.phpのリダイレクトがうまくいってないように見えるのですが,
対処法や解決のヒントをご教示頂けませんでしょうか.

宜しくお願い致します.

コメント(4)

Re: 「ホーム」が正しく表示されない (真っ白またはエラー) 
投稿者: nao-pon | 投稿日時: 2013/11/6 21:48
nao-pon

tsumosan さん、こんにちは。

元々は、正常に表示されていたものが、ある時を境に表示されなくなってしまったということですね。

そして、表示されないのはログインしていない時 = ゲスト の場合ということで、トップページにゲストのみ表示しているブロックに何か問題があるかも知れません。

その辺りを、確認してみるといいかも。

また、html/preload/disabled/OhMyGodHelpMe.class.php を html/preload に移動すると、エラーメッセージは表示されることがあります。

Re: 「ホーム」が正しく表示されない (真っ白またはエラー) 
投稿者: marine | 投稿日時: 2013/11/7 8:09
marine

nao-ponさんの仰るとおり、ゲストに表示されるブロックが怪しそうな気がしますね。

私の経験では、d3pipesの同期パイプ一覧ブロックを利用している場合、一覧表示させている他のサイトがダウンしていると、その表示画面全体が影響を受けて真っ白になったことがあります。

まずは、その辺りをご確認くださいな。
あと、なんかPHPを使ったブロックを表示しているとかはないですか・・・?

手っ取り早くやるなら、とりあえず、ゲスト用の画面で利用しているブロックを一個ずつ非表示にしていって、どこで正常表示できるかで判断できるかと。

#21351 | | 返信する |
Re: 「ホーム」が正しく表示されない (真っ白またはエラー) 
投稿者: tsumosan | 投稿日時: 2013/11/7 14:36 | 親コメント: #21351
tsumosan

marineさん,こんにちは.
早速のフォローを有難うございます.

引用:
手っ取り早くやるなら、とりあえず、ゲスト用の画面で利用しているブロックを一個ずつ非表示にしていって、どこで正常表示できるかで判断できるかと。

これをやってみまして,犯人が分かりました (^_^;).
お蔭様で解決しました.有難うございました.

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top