ホーム > フォーラム > 質問箱 > liaiseのダウングレードまたはファイル送信モジュールについて

liaiseのダウングレードまたはファイル送信モジュールについて
投稿者: miechin | 投稿日時: 2013/12/11 16:40 | 閲覧: 6210回
miechin

お世話になります。
以前、XCL2.1.8で会員向けサイトを作っていたのですが使用せず放置していました。
ここにきて使用が必要となり再開しようと思ったのですが、レンタルサーバのPHPバージョンが5.3に変わってしまったため、5.3を推奨しているXをインストールしアップグレードしました。
インストール後動作確認も終わり、導入していたモジュールLiaiseも特に問題なかったのですが、モジュール管理でLiaise最新版1.31があるとのことだったのでアップグレードした途端、Liaiseはエラーが表示されて動かなくなってしまいました、、
Liaise1.31は、PHP5.3には対応してなかったようで前のバージョンに戻したいのですが
FTPでファイルをサーバへあげたあと、ダウングレードはどうしたらいいのでしょうか?
(サーバへあげただけではダメですよね?)

また、Liaiseで行いたかったことは、ログインしてきた会員の方からファイルを管理者へ送信していただくということなので、もし現在のモジュールでこのような機能があるものがあれば紹介していただけないでしょうか。

どうぞよろしくお願いします。

コメント(4)

Re: liaiseのダウングレードまたはファイル送信モジュールについて 
投稿者: nao-pon | 投稿日時: 2013/12/12 12:02
nao-pon

miechin さん、こんにちは。

X-update で Liaise 1.31 を PHP 5.5.6 の環境にインストールしてみましたが、ファイル送信も含め、動かないといった問題はありませんでした。

PHP のバージョンというより、サーバー設定によるものでしょうか?

ダウングレードは、ファイルを一式アップロードしたあと、モジュール管理よりモジュールアップデートを行えば OK かと思います。

ファイルを管理者へ送信するモジュールについては、私はよく知りませんが、ファイルをアップロードできる拙作の xpWiki とか X-elFinder のパーミッション設定をすることにより、ユーザ <-> 管理者 のファイル共有をおこなうことができます。

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top