ホーム > フォーラム > 質問箱 > XCL2.2 > XeraでXOOPSをインストールしますが完了できません。

XeraでXOOPSをインストールしますが完了できません。
投稿者: suzukisato | 投稿日時: 2014/1/19 14:11 | 閲覧: 10677回
suzukisato

お世話になります。
初心者のため初歩的な質問となりますがご指導いただければ幸いです。
Xeraにて無料サーバを登録し、クイック機能でXoopsをインストールしています。

しかし下記のような画面がでてきており、
インストールが完了していないようです。

Strict Standards: Non-static method TextSanitizer::getInstance() should not be called statically in /virtual/enigma/public_html/xoops/install/index.php on line 37

Warning: Cannot modify header information - headers already sent by (output started at /virtual/enigma/public_html/xoops/install/index.php:37) in /virtual/enigma/public_html/xoops/install/include/functions.php on line 86

Warning: Cannot modify header information - headers already sent by (output started at /virtual/enigma/public_html/xoops/install/index.php:37) in /virtual/enigma/public_html/xoops/install/wizards/install_nextStep.inc.php on line 11

これは何を意味するものでしょうか。
ネットで探すも改善するための方法が見つかりませんでした。
基本的なことで大変申し訳ありませんが、是非改善策をご存じの方はご指導いただけますようお願いいたします。

コメント(3)

新しいものから | 古いものから | ネスト表示 | RSS feed
Re: XeraでXOOPSをインストールしますが完了できません。 
投稿者: suzukisato | 投稿日時: 2014/1/22 20:15 | 親コメント: #21389
suzukisato

nao-ponさん!ありがとうございます!
超初心者のつまらない質問に丁寧にお答えいただき感謝致します!
時間を設けて言われたとおりやってみます!
本当にありがとうございます!

Re: XeraでXOOPSをインストールしますが完了できません。 
投稿者: nao-pon | 投稿日時: 2014/1/22 9:27
nao-pon

XREA の s601 サーバー(PHP 5.5.3, MySQL 5.5.33)にて、XOOPS Cube Legacy をインストールしてみました。

簡単インストールとは、「CGI インストール」のことですね。これでインストールされるのは「XOOPS Cube 2.2.1」で、古いバージョンになるので、PHP 5.4 以降の環境ではエラー表示がされたり、動作に支障がある箇所があったりします。

私も、「CGI インストール」でインストールしてみたところ、インストーラーで進む過程でsuzukisato さんが言われたのと同じエラーがででインストールが最後まで進みませんでした。

そこで、一旦データベースを削除・再作成し「CGI インストール」で配置されたファイルを削除して、install.cgi を使いインストールしたところ、若干エラーメッセージが表示されましたが、それは動作に支障のあるメッセージではなくインストールも無事に完了しました。

ただし、最終段階に設置したサイトのトップページに変遷する場面で、画面が真っ白になりました。これはXREA広告の自動表示が原因で、[設置したサイトのURL]/admin.php にアクセスすることで、最後まで完了でき、その後は大きな問題はありませんでした。

あと、PHP 5.5 系だと XOOPS X の安定バージョンだと、若干動作には支障のないエラーメッセージが表示されることがあります。これらを、修正する試みが開発バージョンで行われており、その開発バージョンに変更することで、それらのエラー表示がほぼ表示されなります。(利用するモジュールによってはモジュールレベルでエラー表示されることがあります)

開発バージョンに変更するには、「管理者メニュー」->「導入・アップデート管理」から「一般設定」を開き、「非表示にされたストアも表示する 」を「はい」にしてください。

すると、「導入・アップデート管理」のトップページの中ほどのタブ表示の中の「モジュール」をクリックすると「For developer」というものが表示されているはずです。その「For developer」をクリックするといくつかの「legacy」がありますのでその中の「( XoopsX_pilot )」の欄の「アップデート」をクリックしてアップデートすると開発バージョンになります。

Re: XeraでXOOPSをインストールしますが完了できません。 
投稿者: nao-pon | 投稿日時: 2014/1/20 9:59
nao-pon

suzukisato さん、こんにちは。

まず、Xera は XREA の間違いでしょうか?ただ XREA だとすると、クイック機能がわからないですが・・・

XCL のバージョンが古いと、PHP 5.4 以上のサーバーでは、表記のエラーメッセージが出ます。

XOOPS X (ten) の install.cgi を利用したインストールをお試しください。

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top