XOOPS Cube日本サイト https://xoopscube.jp/forum?keyword= 最新公開記事 picalを2つ使う場合のlanguageについて https://xoopscube.jp/forum/7266 サイトをリニューアルするにあたりpicalを2つ使いたいくインストールしたのですが、languageが先にロードされた方のものになってしまいます。例languageファイルを下記の書き換えpical では 今日の予定→ 今日の作業 に変更pical1では 今日の予定→ 今日のイベント に変更した場合でpicalの今日の予定ブロックが先にロードされた場合ではpicalでの表示は今日の作業となりpical1の今日の予定ブロックでも今日の作業と表示されてしまうブロックの順番を逆にすると逆のことがおこります。languageは1度しか読み込まないような設定なのでしょうか?よろしくお願いします。

サイトをリニューアルするにあたりpicalを2つ使いたいくインストールしたのですが、languageが先にロードされた方のものになってしまいます。


languageファイルを下記の書き換え
pical では 今日の予定→ 今日の作業 に変更
pical1では 今日の予定→ 今日のイベント に変更
した場合で

picalの今日の予定ブロックが先にロードされた場合ではpicalでの表示は今日の作業となり
pical1の今日の予定ブロックでも今日の作業と表示されてしまう
ブロックの順番を逆にすると逆のことがおこります。

languageは1度しか読み込まないような設定なのでしょうか?
よろしくお願いします。

]]>
COVEt 2019-06-11T18:21+09:00 モジュール開発
ログインするとログイン画面にリダイレクトする。 https://xoopscube.jp/forum/7265 現在、お名前ドットコムのRSサーバをレンタルしています。そこにXoopsXをsetup.cgiにて導入しようとしています。導入自体は、エラーもなく完了するのですが、完了後管理画面へログインをしようとするとログイン処理画面から再度ログイン画面にリダイレクトする状態になっており、ログインができません。お分かりになる方は、ご教授お願い致します。

現在、お名前ドットコムのRSサーバをレンタルしています。
そこにXoopsXをsetup.cgiにて導入しようとしています。
導入自体は、エラーもなく完了するのですが、完了後管理画面へログインをしようとすると
ログイン処理画面から再度ログイン画面にリダイレクトする状態になっており、ログインができません。

お分かりになる方は、ご教授お願い致します。

]]>
assist-eng 2019-05-16T09:32+09:00 その他Ver.(本文に記述)
日本サイトの退会願い https://xoopscube.jp/forum/5731 公式サイトでユーザー名とパスワードを変更したいのですが、そのようなページが見当たらないので、一度退会して、また登録しなおそうと思います。退会手続きを宜しくお願いします。 公式サイトでユーザー名とパスワードを変更したいのですが、
そのようなページが見当たらないので、
一度退会して、また登録しなおそうと思います。
退会手続きを宜しくお願いします。]]>
2008-03-24T16:05+09:00 質問箱
webmap3 このページでは Google マップが正しく読み込まれませんでした https://xoopscube.jp/forum/7264 お世話になっております。 タイトルのように、webmap3 にアクセスすると「このページでは Google マップが正しく読み込まれませんでした」のメッセージが出るようになりました。 Google map の API キーが必要になったようですね。 対応ってお願いできるのでしょうか?

お世話になっております。

 タイトルのように、webmap3 にアクセスすると「このページでは Google マップが正しく読み込まれませんでした」のメッセージが出るようになりました。
 Google map の API キーが必要になったようですね。

 対応ってお願いできるのでしょうか?

]]>
avocet 2018-10-16T11:57+09:00 質問箱
php7環境で、xoopsのモジュールアクセス権限が500エラーで変更できない https://xoopscube.jp/forum/7262 先日はDBバージョン変更に伴う質問でお世話になりました。その節はありがとうございました。お陰様でxoopsサイト全て順調に稼働していたのですが、標記の問題が発生しました。またお力をお貸しいただければと思います。新規にインストール、または既にインストールされているモジュールのアクセス権限を変更しようとすると500エラーが発生します。phpデバグにて取得したエラーログは以下の通りでした。Fatal [PHP]: Uncaught Error: [] operator not supported for strings in /home/(xoops trust pathへのアドレス)/libs/altsys/include/mygroupperm.php:91 Stack trace: #0 /home/(xoops trust pathへのアドレス)/libs/altsys/class/MyBlocksAdmin.class.php(1041): include() #1 /home/(xoops trust pathへのアドレス)/libs/altsys/myblocksadmin.php(57): MyBlocksAdmin->processPost() #2 /home(xoops trust pathへのアドレス)/modules/gnavi/admin.php(40): include('/home/(xoops trust pathへのアドレス)/...') #3 /home/ユーザー名/www/公開側ルートディレクトリ/modules/products/admin/index.php(10): require('/home/(xoops trust pathへのアドレス)/...') #4 {main} thrown in file (trust)/libs/altsys/include/mygroupperm.php line 91 (1)サーバー情報などDistribution : XOOPS X(ten) 20180208XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1使用言語 : ja_utf8オペレーティングシステム : FreeBSDサーバー : ApachePHPバージョン : 7.2.7MySQLのバージョン : 5.5.59-log※mysqlが5.7.21 の環境でも問題が再現します。※php7.19でも問題が再現します※xoopsはホダ塾ディストリビューションからアップグレードしたもの、2018年2月に新規インストールしたもの、全てにおいて問題が発生します。(全てxoops x です)試しにサーバーのphpバージョンを一時的に5.6に戻したところ正常に権限変更が出来ました。できればphp7のままですべてのサイトを運用したいのですが、うまく修復できる方法やアドバイスを頂ければと思います。どうかよろしくお願いいたします。

先日はDBバージョン変更に伴う質問でお世話になりました。その節はありがとうございました。
お陰様でxoopsサイト全て順調に稼働していたのですが、標記の問題が発生しました。またお力をお貸しいただければと思います。

新規にインストール、または既にインストールされているモジュールのアクセス権限を変更しようとすると500エラーが発生します。

phpデバグにて取得したエラーログは以下の通りでした。

Fatal [PHP]: Uncaught Error: [] operator not supported for strings in /home/(xoops trust pathへのアドレス)/libs/altsys/include/mygroupperm.php:91 Stack trace: #0 /home/(xoops trust pathへのアドレス)/libs/altsys/class/MyBlocksAdmin.class.php(1041): include() #1 /home/(xoops trust pathへのアドレス)/libs/altsys/myblocksadmin.php(57): MyBlocksAdmin->processPost() #2 /home(xoops trust pathへのアドレス)/modules/gnavi/admin.php(40): include('/home/(xoops trust pathへのアドレス)/...') #3 /home/ユーザー名/www/公開側ルートディレクトリ/modules/products/admin/index.php(10): require('/home/(xoops trust pathへのアドレス)/...') #4 {main} thrown in file (trust)/libs/altsys/include/mygroupperm.php line 91 (1)

サーバー情報など

Distribution : XOOPS X(ten) 20180208
XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1
使用言語 : ja_utf8
オペレーティングシステム : FreeBSD
サーバー : Apache
PHPバージョン : 7.2.7
MySQLのバージョン : 5.5.59-log

※mysqlが5.7.21 の環境でも問題が再現します。
※php7.19でも問題が再現します
※xoopsはホダ塾ディストリビューションからアップグレードしたもの、2018年2月に新規インストールしたもの、全てにおいて問題が発生します。(全てxoops x です)

試しにサーバーのphpバージョンを一時的に5.6に戻したところ
正常に権限変更が出来ました。

できればphp7のままですべてのサイトを運用したいのですが、うまく修復できる方法やアドバイスを頂ければと思います。
どうかよろしくお願いいたします。

]]>
yoshi34 2018-08-03T16:21+09:00 XCL2.2(Pack 2012)
退会のお願い https://xoopscube.jp/forum/7263 退会の手続きをお願いします

退会の手続きをお願いします

]]>
2018-08-18T23:34+09:00 質問箱
管理者メニューが現れません https://xoopscube.jp/forum/7261 こんにちは 岐阜県クリスタルパークの伊藤という者です管理者メニューが出なくて、HPの書き換えができない状態になってしまいました人事異動等により分かる者もいない状態ですどうしたら良いでしょうか?当方素人ですご教授よろしくお願いいたしますHP http://skate.city.ena.gifu.jp/

こんにちは 岐阜県クリスタルパークの伊藤という者です
管理者メニューが出なくて、HPの書き換えができない状態になってしまいました

人事異動等により
分かる者もいない状態です

どうしたら良いでしょうか?
当方素人です

ご教授よろしくお願いいたします

HP http://skate.city.ena.gifu.jp/

]]>
crystalpk 2018-04-21T15:52+09:00 その他Ver.(本文に記述)
picoの履歴について https://xoopscube.jp/forum/7257 soyogiです。以下の2つのパターンでPICOの履歴についての動きが違うので、何か分かる所がある方は情報頂けませんでしょうか。【A】PHP5.2XOOPS(ホダ塾)(XCL2.1.7)PICO 1.61【B】(新規インストールではなくホダ塾をXにバージョンアップさせたもの)PHP5.3XOOPS X(XCL2.2.3)PICO 1.87症状としては【B】で使用しているPICOの履歴が古い年度のものしか表示されていないという状況です。PICOのページ更新頻度は【A】も【B】も同様に1、2日に数回ある感じなので常に使用はしている状態です。両PICOの一般設定、履歴に関する部分は以下のようにデフォルト設定のままです。・履歴機能を何世代まで保存するか 20・履歴の一世代として保存する最小時間(sec) 300調べた所、PICOの履歴自体の削除機能は無いとの事で削除するにはphpmyadmin等で「(dirname)_content_histories」の各レコードをDELETEというのは分かりましたが、なぜ色々と新しいバージョンである【B】の方が、履歴が更新されなくなってしまったのかが分からない状態です。(【B】は複数サイト構築していますが、どのサイトも同じ状況です)何か情報があれば、お願い致します。

soyogiです。

以下の2つのパターンでPICOの履歴についての動きが違うので、何か分かる所がある方は情報頂けませんでしょうか。

【A】
PHP5.2
XOOPS(ホダ塾)(XCL2.1.7)
PICO 1.61

【B】(新規インストールではなくホダ塾をXにバージョンアップさせたもの)
PHP5.3
XOOPS X(XCL2.2.3)
PICO 1.87

症状としては【B】で使用しているPICOの履歴が古い年度のものしか表示されていないという状況です。
PICOのページ更新頻度は【A】も【B】も同様に1、2日に数回ある感じなので常に使用はしている状態です。

両PICOの一般設定、履歴に関する部分は以下のようにデフォルト設定のままです。
・履歴機能を何世代まで保存するか 20
・履歴の一世代として保存する最小時間(sec) 300

調べた所、PICOの履歴自体の削除機能は無いとの事で削除するにはphpmyadmin等で「(dirname)_content_histories」の各レコードをDELETEというのは分かりましたが、なぜ色々と新しいバージョンである【B】の方が、履歴が更新されなくなってしまったのかが分からない状態です。
(【B】は複数サイト構築していますが、どのサイトも同じ状況です)

何か情報があれば、お願い致します。

]]>
soyogi 2017-07-07T10:19+09:00 質問箱
mysql5.7環境での問題?Altsys xelfinder xoops管理画面 https://xoopscube.jp/forum/7260 昨日、別記事にて https://xoopscube.jp/modules/x/index.php?q=/forum/7259 質問したyoshi34です。上記記事に関してはとりあえず記事内の通り「とりあえず」解決したのですが、また別の問題がみつかりましたのでご報告、そして、知恵をお借りできればと思います。mysql5.7環境において、xoopsモジュールのAltsys,xelfinder,xoops管理画面に問題があります。1、xelfinder画像のアップロードの際に、(ファイルマネージャーを開いた際に)「バックエンドの設定が有効ではありません。読み込み可能なボリュームがありません。」と表示され、画像アップロードが出来ません。2、Altsysテンプレート管理 の画面で、各モジュール名をクリックしても、テンプレート一覧の表が1行しか表示されず、テンプレートの変更が出来ません。新規にテンプレートセットを作成する:は機能しています。テンプレートの高度な設定 で、テンプレートのダウンロード・アップロード共に、ドロップダウンリストで対象テンプレートを選択できない(窓内の表示が --- しかない)3、xoops管理画面の、左側メニューのみ表示されない。自分なりに調べてはみたのですがスキルと知識不足で原因がわかりません。ちなみに、gnavi pico ckeditor4 は問題なく動作しております。記事の制作もできました。現在の環境の詳細は構築環境(さくらレンタルサーバー)Distribution : XOOPS X(ten) 20170328XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1使用言語 : ja_utf8オペレーティングシステム : FreeBSDサーバー : Apache/2.4.29PHPバージョン : 5.6.32MySQLのバージョン : 5.7.20-logmysqlデータベースは構築時にさくらの管理画面でutf8bm4 と utf8 を選択するようになっており、utf8で制作しました。(最初utf8bm4にて制作したところxelfinderとpicoがインストールできなかった)phpmyadminで確認して、照合順序もutf8_general_ciにしてあります。mysql5.5でデータベースを作成できた昨年末までは問題なくサイト構築できておりました。mysql5.7しかデータベース新規作成できない状態のため、困っております。ご教授いただければ幸いです、よろしくお願いいたします。

昨日、別記事にて https://xoopscube.jp/modules/x/index.php?q=/forum/7259 質問したyoshi34です。
上記記事に関してはとりあえず記事内の通り「とりあえず」解決したのですが、また別の問題がみつかりましたのでご報告、そして、知恵をお借りできればと思います。

mysql5.7環境において、xoopsモジュールのAltsys,xelfinder,xoops管理画面に問題があります。

1、xelfinder
画像のアップロードの際に、(ファイルマネージャーを開いた際に)
「バックエンドの設定が有効ではありません。読み込み可能なボリュームがありません。」と表示され、画像アップロードが出来ません。

2、Altsys

テンプレート管理 の画面で、各モジュール名をクリックしても、テンプレート一覧の表が1行しか表示されず、テンプレートの変更が出来ません。新規にテンプレートセットを作成する:は機能しています。

テンプレートの高度な設定 で、テンプレートのダウンロード・アップロード共に、ドロップダウンリストで対象テンプレートを選択できない(窓内の表示が --- しかない)

3、xoops管理画面の、左側メニューのみ表示されない。

自分なりに調べてはみたのですがスキルと知識不足で原因がわかりません。

ちなみに、
gnavi pico ckeditor4 は問題なく動作しております。記事の制作もできました。

現在の環境の詳細は

構築環境(さくらレンタルサーバー)
Distribution : XOOPS X(ten) 20170328
XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1
使用言語 : ja_utf8
オペレーティングシステム : FreeBSD
サーバー : Apache/2.4.29
PHPバージョン : 5.6.32
MySQLのバージョン : 5.7.20-log

mysqlデータベースは構築時にさくらの管理画面で
utf8bm4 と utf8 を選択するようになっており、utf8で制作しました。
(最初utf8bm4にて制作したところxelfinderとpicoがインストールできなかった)
phpmyadminで確認して、照合順序もutf8_general_ciにしてあります。

mysql5.5でデータベースを作成できた昨年末までは問題なくサイト構築できておりました。mysql5.7しかデータベース新規作成できない状態のため、困っております。
ご教授いただければ幸いです、よろしくお願いいたします。

]]>
yoshi34 2018-02-07T11:22+09:00 XCL2.2(Pack 2012)
mysql5.7環境でモジュール pico と xelfinder がインストールできない https://xoopscube.jp/forum/7259 いつも拝見させていただき、参考とさせてもらっております。サイトの新規構築の際に、以下の環境で不具合が発生し困っております。何か情報をお持ちの方、ご教授いただければ幸いです。不具合内容●xoopsインストール後、管理者メニューの左側メニューが表示されない(これに関しては別の管理者テーマ「admin0.24」を組み込んで使用しています)●モジュール「pico」がインストールできない ●モジュール「xelfinder」がインストールできない上記2つに関しては、インストールの最後に「コールバック 'xoops_module_install_モジュール名' を実行することができませんでした」とメッセージが出る。構築環境(さくらレンタルサーバー)Distribution : XOOPS X(ten) 20170328XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1使用言語 : ja_utf8オペレーティングシステム : FreeBSDサーバー : Apache/2.4.29PHPバージョン : 5.6.32MySQLのバージョン : 5.7.20-log気になることは、mysqlのバージョンが5.7という事です。(文字コードはutf8bm4)昨年末に別のサイト構築した際はmysql5.5で、問題なく構築できました。今年に入り、さくらレンタルサーバーの方で「今から新規構築するデータベースは全てmysql5.7で構築するよう」仕様変更されており、mysql5.5での構築はできません。ちなみに、xoops xパック付属の他のモジュール、pical,gnavi,protectorなどは問題なくインストールできております。何か情報をお持ちの方、是非ご教授いただければ幸いです。よろしくお願いいたします。

いつも拝見させていただき、参考とさせてもらっております。
サイトの新規構築の際に、以下の環境で不具合が発生し困っております。
何か情報をお持ちの方、ご教授いただければ幸いです。

不具合内容
●xoopsインストール後、管理者メニューの左側メニューが表示されない
(これに関しては別の管理者テーマ「admin0.24」を組み込んで使用しています)

●モジュール「pico」がインストールできない 
●モジュール「xelfinder」がインストールできない

上記2つに関しては、インストールの最後に「コールバック 'xoops_module_install_モジュール名' を実行することができませんでした」とメッセージが出る。

構築環境(さくらレンタルサーバー)
Distribution : XOOPS X(ten) 20170328
XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1
使用言語 : ja_utf8
オペレーティングシステム : FreeBSD
サーバー : Apache/2.4.29
PHPバージョン : 5.6.32
MySQLのバージョン : 5.7.20-log

気になることは、mysqlのバージョンが5.7という事です。(文字コードはutf8bm4)

昨年末に別のサイト構築した際はmysql5.5で、問題なく構築できました。
今年に入り、さくらレンタルサーバーの方で「今から新規構築するデータベースは全てmysql5.7で構築するよう」仕様変更されており、mysql5.5での構築はできません。

ちなみに、xoops xパック付属の他のモジュール、pical,gnavi,protectorなどは問題なくインストールできております。

何か情報をお持ちの方、是非ご教授いただければ幸いです。よろしくお願いいたします。

]]>
yoshi34 2018-02-05T09:55+09:00 XCL2.2(Pack 2012)
ウェブフォームを使用によって送信されたメールが文字化けします。 https://xoopscube.jp/forum/7258 ウェブサイトからの申し込み等をWebフォームを使って入力内容がユーザの登録メールあてに送信される仕組みを使用しています。 そこで、入力内容をメールで受け取るとメール本文、件名などが文字化けしています。Webフォームからの送信者情報を管理画面で確認すると文字化けされていません。データベースの値も文字化けされていません。このケースで考えられる事象は何でしょうか。仕様バージョン:XOOPS Cube Legacy 2.2.2 Beta1使用言語 : ja_utf8

ウェブサイトからの申し込み等をWebフォームを使って入力内容がユーザの登録メールあてに送信される仕組みを使用しています。

 そこで、入力内容をメールで受け取るとメール本文、件名などが文字化けしています。
Webフォームからの送信者情報を管理画面で確認すると文字化けされていません。
データベースの値も文字化けされていません。

このケースで考えられる事象は何でしょうか。

仕様バージョン:XOOPS Cube Legacy 2.2.2 Beta1
使用言語 : ja_utf8

]]>
ujin 2018-01-15T17:47+09:00 XCL2.2
ssl化における混在コンテンツについて https://xoopscube.jp/forum/7256 xoopsXを使わせて頂いておりますが、この度、SSL化したのですが、Firefoxで見た所、以下の部分が混在コンテンツになっているようです。混在アクティブコンテンツ“http://ドメイン/xoops.css” の読み込みをブロックしました“http://ドメイン/themes/テンプレート/style.css” の読み込みをブロックしました“http://ドメイン/include/xoops.js” の読み込みをブロックしました“http://ドメイン/themes/テンプレート/images/logo.gif”この部分をhttpsに変えればいいと思いますが、これらは、どのフォルダーとかに入っているんでしょうか?初歩的な事と思いますが、教えて下さい。

xoopsXを使わせて頂いておりますが、この度、SSL化したのですが、Firefoxで見た所、以下の部分が混在コンテンツになっているようです。

混在アクティブコンテンツ

http://ドメイン/xoops.css” の読み込みをブロックしました

http://ドメイン/themes/テンプレート/style.css” の読み込みをブロックしました

http://ドメイン/include/xoops.js” の読み込みをブロックしました

http://ドメイン/themes/テンプレート/images/logo.gif”

この部分をhttpsに変えればいいと思いますが、これらは、どのフォルダーとかに入っているんでしょうか?

初歩的な事と思いますが、教えて下さい。

]]>
tamayula 2017-05-16T19:19+09:00 質問箱
XOOPS Cube 日本サイトのフォーラムのRSSフィードについて https://xoopscube.jp/forum/7255 いつも、お世話になっています。XOOPS Cube 日本サイトのフォーラムのRSSフィードに「最終の返信」に関する情報が含まれていないので、本来のフォーラムの最新投稿一覧が取得できません。しかし、トップページにあるフォーラムの最新情報だと「最終の返信」に関する情報が含まれており、本来のフォーラムの最新投稿一覧が表示されています。出来れば、フォーラムのRSSフィードの改善を希望します。

いつも、お世話になっています。

XOOPS Cube 日本サイトのフォーラムのRSSフィードに「最終の返信」に関する情報が含まれていないので、本来のフォーラムの最新投稿一覧が取得できません。

しかし、トップページにあるフォーラムの最新情報だと「最終の返信」に関する情報が含まれており、本来のフォーラムの最新投稿一覧が表示されています。

出来れば、フォーラムのRSSフィードの改善を希望します。

]]>
pcboy 2017-03-21T15:39+09:00 その他
d3downloads でダウンロードすると拡張子が消える https://xoopscube.jp/forum/7254 お世話になります。 XOOPSでサイト構築しています。サイトの環境は末尾に示します。 d3downloads でアップロードしたファイルをダウンロードしようとすると拡張子が消えてしまいます。 ブラウザは Chrome(バージョン 56.0.2924.87)とマイクロソフト Edge です、ファイル名へのマウスオンでは平常にファイル名が表示されますが、ダウンロードすると Chrome の場合はたとえば filename.pdf が filename- となります。 Edge では filename.txt になります  (この場合は拡張子のないファイルは既定でテキストエディタで開く設定になっているためと思われます) IE11 の場合は日本語ファイル名は文字化けしますが、拡張子は消えずにダウンロードできます。  文字化けは http://www.illareya.net/help/ie11_download_error_bug/01.html のやり方で解消できます。 なお、クライアントPCは windows10 です。 ソースを覗いてみました。  xoops_trust_path/modules/d3downloads/include フォルダ内の download_functions.php ファイルの 121 行以降の関数 d3download_chrome_filenameでの処理で拡張子が切り取られているようです。この関数を通さないようにすると、とりあえずは正常にダウンロード出来るようです。 なぜこのような処理をしているのか? また、この処理をパスして使い続けて問題ないのか?それから IE11 の文字化けはサーバー(d3downloads)側の設定を変える事で避けることが出来るのか? 以上、ご教示いただければ幸いです。よろしく願いいたします。サーバーの環境 XOOPS Cube Legacy 2.2.1 LANGUAGE japanese EUC-JP SERVER Apache PHP 5.2.11 MySQL 5.1.51 d3downloads v1.5

お世話になります。

 XOOPSでサイト構築しています。
サイトの環境は末尾に示します。

 d3downloads でアップロードしたファイルをダウンロードしようとすると拡張子が消えてしまいます。
 ブラウザは Chrome(バージョン 56.0.2924.87)とマイクロソフト Edge です、ファイル名へのマウスオンでは平常にファイル名が表示されますが、ダウンロードすると

 Chrome の場合はたとえば filename.pdf が filename- となります。
 Edge では filename.txt になります
  (この場合は拡張子のないファイルは既定でテキストエディタで開く設定になっているためと思われます)
 IE11 の場合は日本語ファイル名は文字化けしますが、拡張子は消えずにダウンロードできます。
  文字化けは http://www.illareya.net/help/ie11_download_error_bug/01.html のやり方で解消できます。

 なお、クライアントPCは windows10 です。

 ソースを覗いてみました。 

 xoops_trust_path/modules/d3downloads/include フォルダ内の
 download_functions.php ファイルの 121 行以降の関数 d3download_chrome_filename
での処理で拡張子が切り取られているようです。
この関数を通さないようにすると、とりあえずは正常にダウンロード出来るようです。

 なぜこのような処理をしているのか? また、この処理をパスして使い続けて問題ないのか?
それから IE11 の文字化けはサーバー(d3downloads)側の設定を変える事で避けることが出来るのか?

 以上、ご教示いただければ幸いです。よろしく願いいたします。

サーバーの環境
 XOOPS Cube Legacy 2.2.1
 LANGUAGE japanese EUC-JP
 SERVER Apache
 PHP 5.2.11
 MySQL 5.1.51
 d3downloads v1.5

]]>
avocet 2017-03-11T12:01+09:00 質問箱
急にアクセスできなくなりました。 https://xoopscube.jp/forum/7253 初心者ですがよろしくお願いいたします。CL2.1を使用しております。レンタルサーバーで複数サイトを運用しております。数日前からAのサイトのみ、ログインできません。管理者IDでも、一般ユーザーIDでもです。IDパスワードを入れると、「ログイン処理中」から元の入力フォームに戻ってしまいます。どうやらループしているようです。ちなみに 適当な文字を入れると 「ログイン情報が間違っています」と処理されます。IE11の信頼サイトにも登録済みです。FIREFOXで試してもだめでした。サイトBやCでは正しくログインできます。対応策をご教授いただけたらと思います

初心者ですがよろしくお願いいたします。

CL2.1を使用しております。
レンタルサーバーで複数サイトを運用しております。
数日前からAのサイトのみ、ログインできません。
管理者IDでも、一般ユーザーIDでもです。
IDパスワードを入れると、「ログイン処理中」から元の入力フォームに戻ってしまいます。
どうやらループしているようです。
ちなみに 適当な文字を入れると 「ログイン情報が間違っています」と処理されます。
IE11の信頼サイトにも登録済みです。
FIREFOXで試してもだめでした。
サイトBやCでは正しくログインできます。

対応策をご教授いただけたらと思います

]]>
dperie 2016-10-27T11:04+09:00 XCL2.1.0
xelfinderのエラーメッセージについて https://xoopscube.jp/forum/7252 いつもモジュールを利用させていただきありがとうございます。掲題の件、2.01に上げたら、「バックエンドとの接続ができません」とメッセージがでて次に行きません。どのモジュールの部分を修正したら、以前の状態になりますでしょうか?サイト情報は以下のようになります。Distribution : XOOPS X(ten) 20151228XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1デフォルト・サイトテーマ : r_simple_blueデフォルトのテンプレート・セット : default使用言語 : ja_utf8デバッグモードを有効にする : オフオペレーティングシステム : FreeBSDサーバー : Apache/2.2.29ユーザーエージェント : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0PHPバージョン : 5.2.17MySQLのバージョン : 5.5.38-log

いつもモジュールを利用させていただきありがとうございます。

掲題の件、
2.01に上げたら、
「バックエンドとの接続ができません」とメッセージがでて次に行きません。

どのモジュールの部分を修正したら、以前の状態になりますでしょうか?

サイト情報は以下のようになります。

Distribution : XOOPS X(ten) 20151228
XC Legacyバージョン : XOOPS Cube Legacy 2.2.3 Beta 1
デフォルト・サイトテーマ : r_simple_blue
デフォルトのテンプレート・セット : default
使用言語 : ja_utf8
デバッグモードを有効にする : オフ
オペレーティングシステム : FreeBSD
サーバー : Apache/2.2.29
ユーザーエージェント : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
PHPバージョン : 5.2.17
MySQLのバージョン : 5.5.38-log

]]>
terrafin 2016-02-09T23:15+09:00 質問箱
2.2へのアップグレード https://xoopscube.jp/forum/7249 いくつかのXOOPSサイト(XOOPS 2.0.16a JP)を運営してきたのですが、今年(2015年)9月末にすべてのサイトでフォーラム投稿表示のフォーラム名、スレッド項目が表示されなくなり、運営がストップしてしまいました。日本語データのデータベースとのやりとりに問題が起きたのだとは思うのですが、その原因、解決方法がわかりません。XOOPSサイトのアップグレードを怠ったままでしたので、とりあえずテスト用のサイトで、最新版へのアップグレードを試みました。(XCL2.1.8)へのアップグレードは一応完了したのですが、管理画面に入ると、トップページのフォーラム同様、各項目の表示がありません。最新版(legacy-stable、2.2.2)に期待を込めてそのままアップグレードを作業し立ち上げると、'FETAL: open error: site setting config.'のエラーメッセージであとは真っ白。そこで'XCL2.18(EUC)をpack2011(XCL2.2 UTF-8)にアップグレードしてみよう!'を頼りにローカルPC上にサーバー環境を作り、試してみました。そうしたら、当面の問題だったフォーラム投稿表示のフォーラム名、スレッド項目が'XOOPS 2.0.16a JP'のままの時点で何の問題もなく表示され、そのままローカル環境では何の問題もなく、最新版(legacy-stable、2.2.2)までアップグレードできました。最使用サーバー、PHP5.4、MySQL5.5ローカル環境、PHP5.5、MySQL5.6 です。最終的にやはり、サーバー上で最新バージョンでのつつがない運営をいたしたく、ご助言をいただけたらと思います。

いくつかのXOOPSサイト(XOOPS 2.0.16a JP)を運営してきたのですが、今年(2015年)9月末にすべてのサイトでフォーラム投稿表示のフォーラム名、スレッド項目が表示されなくなり、運営がストップしてしまいました。

日本語データのデータベースとのやりとりに問題が起きたのだとは思うのですが、その原因、解決方法がわかりません。XOOPSサイトのアップグレードを怠ったままでしたので、とりあえずテスト用のサイトで、最新版へのアップグレードを試みました。

(XCL2.1.8)へのアップグレードは一応完了したのですが、管理画面に入ると、トップページのフォーラム同様、各項目の表示がありません。

最新版(legacy-stable、2.2.2)に期待を込めてそのままアップグレードを作業し立ち上げると、'FETAL: open error: site setting config.'のエラーメッセージであとは真っ白。

そこで'XCL2.18(EUC)をpack2011(XCL2.2 UTF-8)にアップグレードしてみよう!'を頼りにローカルPC上にサーバー環境を作り、試してみました。

そうしたら、当面の問題だったフォーラム投稿表示のフォーラム名、スレッド項目が'XOOPS 2.0.16a JP'のままの時点で何の問題もなく表示され、そのままローカル環境では何の問題もなく、最新版(legacy-stable、2.2.2)までアップグレードできました。

最使用サーバー、PHP5.4、MySQL5.5
ローカル環境、PHP5.5、MySQL5.6 です。

最終的にやはり、サーバー上で最新バージョンでのつつがない運営をいたしたく、ご助言をいただけたらと思います。

]]>
KSL 2015-12-02T16:26+09:00 XCL2.2(Pack 2012)
myalbim-PでHOME画面にとんでしまう。 https://xoopscube.jp/forum/7251 お世話になります。xoopsXでmyalbim-Pを導入しました。投稿をする際に「大きさ」「フォント」「色」を変更しようとクリックするとHOME画面にとんでしまいます。カテゴリを選ぶ際にもなります。本来クリックのできない場所も、クリックできるようになってしまい、すべてHOME画面にとんでしまいます。インストール当初は問題なく使えていましたが、いつからダメになったのか心当たりがありません。モジュールを再インストールしてもだめでした。同じ現象がgnaviでも発生しました。解決策ご存じの方いたら、よろしくお願いします。

お世話になります。

xoopsXでmyalbim-Pを導入しました。

投稿をする際に「大きさ」「フォント」「色」を変更しようとクリックすると
HOME画面にとんでしまいます。
カテゴリを選ぶ際にもなります。

本来クリックのできない場所も、クリックできるようになってしまい、
すべてHOME画面にとんでしまいます。

インストール当初は問題なく使えていましたが、
いつからダメになったのか心当たりがありません。
モジュールを再インストールしてもだめでした。

同じ現象がgnaviでも発生しました。

解決策ご存じの方いたら、よろしくお願いします。

]]>
mochimu 2016-01-16T23:32+09:00 質問箱
piCalモジュールが削除できない https://xoopscube.jp/forum/7250 Xoopsのバックアップを削除したところ、\modules\piCal\language\japaneseにあるmail_templateフォルダmodinfo.phppical_constants.phppical_vars.phtmlを削除すると、下記のエラーがでます。「無効なMS-DOSファンクションです。」DOSコマンドでも削除できません。対応を教えてください。

Xoopsのバックアップを削除したところ、
\modules\piCal\language\japaneseにある
mail_templateフォルダ
modinfo.php
pical_constants.php
pical_vars.phtml
を削除すると、下記のエラーがでます。
「無効なMS-DOSファンクションです。」
DOSコマンドでも削除できません。

対応を教えてください。

]]>
chii_fu 2015-12-29T18:09+09:00 質問箱
session.cookie_secure をオンにするとログインできない https://xoopscube.jp/forum/7247 XOOPS Cube Legacy 2.1.8でポータルサイトを運営していますが、php.iniでsession.cookie_secure=1にするとログインできなくなります。session.cookie_secure=1でxoopsが上手く稼働できている方、是非回避策をご教示下さい。

XOOPS Cube Legacy 2.1.8でポータルサイトを運営していますが、php.iniでsession.cookie_secure=1にするとログインできなくなります。
session.cookie_secure=1でxoopsが上手く稼働できている方、是非回避策をご教示下さい。

]]>
chibayan 2015-11-06T10:04+09:00 XCL2.1.8