XOOPS Cube日本サイト (XCL2.2) https://xoopscube.jp/forum?category_id=29&keyword= 最新公開記事 ウェブフォームを使用によって送信されたメールが文字化けします。 https://xoopscube.jp/forum/7258 ウェブサイトからの申し込み等をWebフォームを使って入力内容がユーザの登録メールあてに送信される仕組みを使用しています。 そこで、入力内容をメールで受け取るとメール本文、件名などが文字化けしています。Webフォームからの送信者情報を管理画面で確認すると文字化けされていません。データベースの値も文字化けされていません。このケースで考えられる事象は何でしょうか。仕様バージョン:XOOPS Cube Legacy 2.2.2 Beta1使用言語 : ja_utf8

ウェブサイトからの申し込み等をWebフォームを使って入力内容がユーザの登録メールあてに送信される仕組みを使用しています。

 そこで、入力内容をメールで受け取るとメール本文、件名などが文字化けしています。
Webフォームからの送信者情報を管理画面で確認すると文字化けされていません。
データベースの値も文字化けされていません。

このケースで考えられる事象は何でしょうか。

仕様バージョン:XOOPS Cube Legacy 2.2.2 Beta1
使用言語 : ja_utf8

]]>
ujin 2018-01-15T17:47+09:00 XCL2.2
インストールの完了の後にPHP設定で赤字が出ている件について https://xoopscube.jp/forum/7233 初めて投稿させていただきます隆成と申します。coreserverにてインストールを完了させました。そこでPHPの設定で4か所赤字が出ています。XOOPS Cube legacy2.2.3Beta1デバッグモード PHPデバグPHP バージョン 5.3.29MySQL   5.1.73の設定で表示エラー 赤字でオフ出力バファリング 赤字でオフopen_basedir 赤字でオフurl_fopenを許可 赤字でオン (recommended OFF)というものが表示されています。これについては何かの設定を促すような説明がありあせん。WEBで探しましたが関連づけできるような対処が見当たりませんでした。この件でご教授いただければ幸いです。よろしくお願いもうしあげます。

初めて投稿させていただきます
隆成と申します。

coreserverにてインストールを完了させました。

そこでPHPの設定で4か所赤字が出ています。

XOOPS Cube legacy2.2.3Beta1
デバッグモード PHPデバグ
PHP バージョン 5.3.29
MySQL   5.1.73

の設定で

表示エラー 赤字でオフ

出力バファリング 赤字でオフ

open_basedir 赤字でオフ

url_fopenを許可 赤字でオン (recommended OFF)

というものが表示されています。

これについては何かの設定を促すような
説明がありあせん。

WEBで探しましたが
関連づけできるような対処が見当たりませんでした。

この件でご教授いただければ幸いです。
よろしくお願いもうしあげます。

]]>
ryusei999 2015-05-22T10:34+09:00 XCL2.2
xcl2.2.3beta1でmail_template内のメール内容を変更しても反映されない https://xoopscube.jp/forum/7227 おせわになります。掲題の通りxcl2.2.3beta1でmail_template内のメール内容を変更しても反映されず困っています。languageにはenglishとja_utf8の2つのフォルダがあり、試しにその両方のフォルダ内のファイルの中身を書き換えてみたのですが、例えばパスワード再発行のリクエストをしたときに送られてくるメールの内容(lostpass1.tpl)が、やはりデフォルトのままです。キャッシュが効いてるのかと思い、trustpassのcacheフォルダの中身を削除してみましたが、変化有りませんでした。どなたか解決策をアドバイスいただけないでしょうか。よろしくおねがいします。

おせわになります。

掲題の通りxcl2.2.3beta1でmail_template内のメール内容を変更しても反映されず困っています。

languageにはenglishとja_utf8の2つのフォルダがあり、試しにその両方のフォルダ内のファイルの中身を書き換えてみたのですが、例えばパスワード再発行のリクエストをしたときに送られてくるメールの内容(lostpass1.tpl)が、やはりデフォルトのままです。

キャッシュが効いてるのかと思い、trustpassのcacheフォルダの中身を削除してみましたが、変化有りませんでした。どなたか解決策をアドバイスいただけないでしょうか。
よろしくおねがいします。

]]>
Yoshi2006 2015-02-15T12:26+09:00 XCL2.2
ユーザー認証なしでHPをみるための設定 https://xoopscube.jp/forum/7201 はじめまして、今日はじめてXoops 2.2をインストールして使いはじめました。質問内容ユーザー登録していない人がHP訪れるケースがおおいと思うのですが、登録なしでHPを見れるようにするためにどのモジュール設定を変更すればいいのでしょうか?現在の状況インストール後、管理者としてログインしている時はHP表示されます。ログアウト後に同じURLで表示させると会員登録画面が表示されます。ネットで同じ質問がないか検索すると古い情報のため解決に至りませんでした。試しに触ってみたのは下記の方法管理画面>ユーザーモジュール>グループ管理>ゲスト>ブロックアクセス権限>アクセスのチェックリストにチェック。やはりゲスト状態ではログイン状態のようには見れず。この設定は間違いでしょうか?正しい設定方法お教え下さい。よろしくお願いします。

はじめまして、今日はじめてXoops 2.2をインストールして使いはじめました。

質問内容
ユーザー登録していない人がHP訪れるケースがおおいと思うのですが、登録なしでHPを見れるようにするためにどのモジュール設定を変更すればいいのでしょうか?

現在の状況
インストール後、管理者としてログインしている時はHP表示されます。
ログアウト後に同じURLで表示させると会員登録画面が表示されます。
ネットで同じ質問がないか検索すると古い情報のため解決に至りませんでした。

試しに触ってみたのは下記の方法
管理画面>ユーザーモジュール>グループ管理>ゲスト>ブロックアクセス権限>アクセスのチェックリストにチェック。

やはりゲスト状態ではログイン状態のようには見れず。
この設定は間違いでしょうか?

正しい設定方法お教え下さい。
よろしくお願いします。

]]>
rocksoco 2014-05-21T01:26+09:00 XCL2.2
データベースの値が1日1回消えるのですが、対処方法をアドバイス頂けないでしょうか。 https://xoopscube.jp/forum/7188 今回初めてXOOPS Cubeを使う初心者です。XOOPS Cube Legacy 2.2.2 RC2 を使って、ユーザー向けのサービスを作ったのですが、ユーザーモジュールの中の本名の値だけが、定期的に1日1回ランダムに消されてしまいます。phpmyadmin上からも本名に相当する、nameの値が消えています。1日1回というところから、何かバッチ処理などで、消されてしまっているのかと思い、cronで検索してみようと思ったのですが、wappyを使っているために、sshログインは禁止されており、確認することができません。何か良い対処方法または、実際に直したケースなどをご存知の方がいらっしゃいましたら、ご教授いただけないでしょうか。バッチ処理の走るようなものを設定してはいないはずなのですが、デフォルトで走るようなものが入っているようでしたら、それについても教えて頂ければ嬉しいです。よろしくお願いいたします。

今回初めてXOOPS Cubeを使う初心者です。
XOOPS Cube Legacy 2.2.2 RC2 を使って、ユーザー向けのサービスを作ったのですが、
ユーザーモジュールの中の本名の値だけが、定期的に1日1回ランダムに消されてしまいます。
phpmyadmin上からも本名に相当する、nameの値が消えています。

1日1回というところから、何かバッチ処理などで、消されてしまっているのかと思い、
cronで検索してみようと思ったのですが、wappyを使っているために、sshログインは禁止されており、確認することができません。

何か良い対処方法または、実際に直したケースなどをご存知の方がいらっしゃいましたら、ご教授いただけないでしょうか。
バッチ処理の走るようなものを設定してはいないはずなのですが、デフォルトで走るようなものが入っているようでしたら、それについても教えて頂ければ嬉しいです。

よろしくお願いいたします。

]]>
syuka 2014-02-12T13:38+09:00 XCL2.2
ユーザーの新規登録をしますが、承認キーメールが送信されません。 https://xoopscube.jp/forum/7184 初心者です。つまらない質問をしておりましたら申し訳ありません。XoopsX(ten)を使用し、サーバーは無料アカウントでXreaを利用しています。インストールも問題なく完了し、Xoopsコンフィグでメール設定も完了しました。メール送信方法をPHPMAIL()やSMTP、SMTPAuthに設定しても承認キーメールが送信されません。捨てアドで新規登録しますが、無事に送信され承認キーメールをお待ちくださいとなります。それでも承認キーは届きません。googleで検索すると同様に承認キーメールが送信されないケースがあるようですが、具体的な改善策が見つかりません。この不具合は改善されていないのでしょうか?もし具体的に改善策をご存知であればご指導いただけると幸いです。何卒宜しくお願いいたします。

初心者です。
つまらない質問をしておりましたら申し訳ありません。

XoopsX(ten)を使用し、サーバーは無料アカウントでXreaを利用しています。
インストールも問題なく完了し、Xoopsコンフィグでメール設定も完了しました。

メール送信方法をPHPMAIL()やSMTP、SMTPAuthに設定しても承認キーメールが送信されません。

捨てアドで新規登録しますが、無事に送信され承認キーメールをお待ちくださいとなります。
それでも承認キーは届きません。
googleで検索すると同様に承認キーメールが送信されないケースがあるようですが、
具体的な改善策が見つかりません。

この不具合は改善されていないのでしょうか?

もし具体的に改善策をご存知であればご指導いただけると幸いです。

何卒宜しくお願いいたします。

]]>
suzukisato 2014-01-23T23:20+09:00 XCL2.2
XeraでXOOPSをインストールしますが完了できません。 https://xoopscube.jp/forum/7183 お世話になります。初心者のため初歩的な質問となりますがご指導いただければ幸いです。Xeraにて無料サーバを登録し、クイック機能でXoopsをインストールしています。しかし下記のような画面がでてきており、インストールが完了していないようです。Strict Standards: Non-static method TextSanitizer::getInstance() should not be called statically in /virtual/enigma/public_html/xoops/install/index.php on line 37Warning: Cannot modify header information - headers already sent by (output started at /virtual/enigma/public_html/xoops/install/index.php:37) in /virtual/enigma/public_html/xoops/install/include/functions.php on line 86Warning: Cannot modify header information - headers already sent by (output started at /virtual/enigma/public_html/xoops/install/index.php:37) in /virtual/enigma/public_html/xoops/install/wizards/install_nextStep.inc.php on line 11これは何を意味するものでしょうか。ネットで探すも改善するための方法が見つかりませんでした。基本的なことで大変申し訳ありませんが、是非改善策をご存じの方はご指導いただけますようお願いいたします。

お世話になります。
初心者のため初歩的な質問となりますがご指導いただければ幸いです。
Xeraにて無料サーバを登録し、クイック機能でXoopsをインストールしています。

しかし下記のような画面がでてきており、
インストールが完了していないようです。

Strict Standards: Non-static method TextSanitizer::getInstance() should not be called statically in /virtual/enigma/public_html/xoops/install/index.php on line 37

Warning: Cannot modify header information - headers already sent by (output started at /virtual/enigma/public_html/xoops/install/index.php:37) in /virtual/enigma/public_html/xoops/install/include/functions.php on line 86

Warning: Cannot modify header information - headers already sent by (output started at /virtual/enigma/public_html/xoops/install/index.php:37) in /virtual/enigma/public_html/xoops/install/wizards/install_nextStep.inc.php on line 11

これは何を意味するものでしょうか。
ネットで探すも改善するための方法が見つかりませんでした。
基本的なことで大変申し訳ありませんが、是非改善策をご存じの方はご指導いただけますようお願いいたします。

]]>
suzukisato 2014-01-19T14:11+09:00 XCL2.2
Captcha 0.20 https://xoopscube.jp/forum/7173 xoops若輩者でございます。よろしくお願いいたします。captcha 0.20の作者でおられる大和田様のはっぴぃりなっくすのフォーラムで質問しようとしましたが、スパム対策からか、現在新規登録をお控えになり質問できなかったので、ご迷惑かとわたしも悩んだ挙句、直接、大和田様に問い合わせでメールを送らせていただきましたが、お忙しいからか、御返事をいただけなかったので、こちらのXOOPS Cube様で質問させていただき、若輩者ではございますが、何としても問題解決に至りたいので、何卒、お力添えをお願いいたします。、日本語ドメインを取得、サイト構築中、captcha 0.20をエラーなくインストールできましたが、管理画面のCaptcha Test Formにてキャプチャ画像が出て来ません。動作環境は、以下の通りです。(Apacheを加えた以外、webphotoの動作チェッカーからの抜粋です)XOOPS: XOOPS Cube Legacy 2.2OS: Linux dti-vps x86_64Apache2.2.15PHP: 5.3.3MySQL: 5.1.69MySQL 設定character_set_client: utf8character_set_connection: utf8character_set_database: utf8character_set_filesystem: binarycharacter_set_results: utf8character_set_server: utf8character_set_system: utf8PHP設定register_globals: off ( 推奨 off )allow_url_fopen: off ( 推奨 off )file_uploads: on ( 要on )upload_max_filesize: 2Mpost_max_size: 8Mupload_tmp_dir :error_reporting: 30719display_errors: 0memory_limit: 128magic_quotes_gpc: 0safe_mode: 0open_basedir:exif extention: loadedマルチバイト 設定multibyte function priority: iconvmbstring.language: Japanesembstring.detect_order: UTF-8 SJIS EUC-JP JIS ASCIImbstring.http_input: passmbstring.http_output: passmbstring.internal_encoding: UTF-8mbstring.script_encoding:mbstring.substitute_character: nonembstring.func_overload: 0mbstring.encoding_translation: 0mbstring.strict_encoding: 0iconv.input_encoding: UTF-8iconv.output_encoding: UTF-8iconv.internal_encoding: UTF-8設定チェック画像処理プログラム :GDGD Version: bundled (2.0.34 compatible)ImageMagickPath: /usr/bin/Version: ImageMagick 6.5.4-7 2012-05-07 Q16 OpenMP http://www.imagemagick.orghtml以下に配置した、captcha.phpを、<?php/* ↓↓↓コメントアウトここからif ( file_exists('mainfile.php') ){ include 'mainfile.php';}elseif ( file_exists('../../mainfile.php') ){ include '../../mainfile.php';}include_once XOOPS_ROOT_PATH.'/modules/captcha/class/captcha_x/class.captcha_x.php';/ ↑↑↑ ここまで/* ↓↓↓ 付け加えた部分ここから */include_once ( 'modules/captcha/class/captcha_x/class.captcha_x.php');/ ↑↑↑ ここまで */// Assigning the return value of new by reference is deprecated$captcha_x = new captcha_x();$captcha_x->handle_request();?>とすると、管理画面のCaptcha Test Formで、キャプチャ画像は出るのですが、キャプチャテストをしようとして正しく文字をタイプしても、Test NGが出てしまい、Liaise 1.31でも画像は出て来ますが、正しく文字を入力しても、画像認証エラーが出てしまいます。上記のコメントアウトを外し、付け加えた部分を削除、すなわち、何もいじらないと、キャプチャ画像が出なくなってしまいます。デバッグには、CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), default quality、と出くてくるので、<?php の前に、空白、改行などないかチェックしたり、UTF-8N、ボム無しも試みました。他の方と違うところと言えば、あとは日本語ドメインくらいなので、それが影響してるのかなぁと、xoopsはもちろん、プログラミングの素人のわたしは思うのですが、どうすればキャプチャ画像が出て、且つ正しく機能するようになるのか教えていただきたく、お忙しいところ恐縮ではございますが、何卒、何卒ご教示ををお願いいたします。

xoops若輩者でございます。よろしくお願いいたします。

captcha 0.20の作者でおられる大和田様のはっぴぃりなっくすのフォーラムで質問しようとしましたが、スパム対策からか、現在新規登録をお控えになり質問できなかったので、ご迷惑かとわたしも悩んだ挙句、直接、大和田様に問い合わせでメールを送らせていただきましたが、お忙しいからか、御返事をいただけなかったので、こちらのXOOPS Cube様で質問させていただき、若輩者ではございますが、何としても問題解決に至りたいので、何卒、お力添えをお願いいたします。

日本語ドメインを取得、サイト構築中、captcha 0.20をエラーなくインストールできましたが、管理画面のCaptcha Test Formにてキャプチャ画像が出て来ません。

動作環境は、以下の通りです。(Apacheを加えた以外、webphotoの動作チェッカーからの抜粋です)

XOOPS: XOOPS Cube Legacy 2.2
OS: Linux dti-vps x86_64
Apache2.2.15
PHP: 5.3.3
MySQL: 5.1.69

MySQL 設定

character_set_client: utf8
character_set_connection: utf8
character_set_database: utf8
character_set_filesystem: binary
character_set_results: utf8
character_set_server: utf8
character_set_system: utf8

PHP設定

register_globals: off ( 推奨 off )
allow_url_fopen: off ( 推奨 off )
file_uploads: on ( 要on )
upload_max_filesize: 2M
post_max_size: 8M
upload_tmp_dir :
error_reporting: 30719
display_errors: 0
memory_limit: 128
magic_quotes_gpc: 0
safe_mode: 0
open_basedir:
exif extention: loaded

マルチバイト 設定

multibyte function priority: iconv

mbstring.language: Japanese
mbstring.detect_order: UTF-8 SJIS EUC-JP JIS ASCII
mbstring.http_input: pass
mbstring.http_output: pass
mbstring.internal_encoding: UTF-8
mbstring.script_encoding:
mbstring.substitute_character: none
mbstring.func_overload: 0
mbstring.encoding_translation: 0
mbstring.strict_encoding: 0

iconv.input_encoding: UTF-8
iconv.output_encoding: UTF-8
iconv.internal_encoding: UTF-8

設定チェック

画像処理プログラム :

GD
GD Version: bundled (2.0.34 compatible)

ImageMagick
Path: /usr/bin/
Version: ImageMagick 6.5.4-7 2012-05-07 Q16 OpenMP http://www.imagemagick.org

html以下に配置した、captcha.phpを、

<?php

/* ↓↓↓コメントアウトここから

if ( file_exists('mainfile.php') )
{

   include 'mainfile.php';

}

elseif ( file_exists('../../mainfile.php') )
{

   include '../../mainfile.php';

}

include_once XOOPS_ROOT_PATH.'/modules/captcha/class/captcha_x/class.captcha_x.php';

/ ↑↑↑ ここまで

/* ↓↓↓ 付け加えた部分ここから */

include_once ( 'modules/captcha/class/captcha_x/class.captcha_x.php');

/ ↑↑↑ ここまで */

// Assigning the return value of new by reference is deprecated
$captcha_x = new captcha_x();

$captcha_x->handle_request();

?>

とすると、管理画面のCaptcha Test Formで、キャプチャ画像は出るのですが、キャプチャテストをしようとして正しく文字をタイプしても、Test NGが出てしまい、Liaise 1.31でも画像は出て来ますが、正しく文字を入力しても、画像認証エラーが出てしまいます。

上記のコメントアウトを外し、付け加えた部分を削除、すなわち、何もいじらないと、キャプチャ画像が出なくなってしまいます。

デバッグには、CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), default quality、と出くてくるので、<?php の前に、空白、改行などないかチェックしたり、UTF-8N、ボム無しも試みました。

他の方と違うところと言えば、あとは日本語ドメインくらいなので、それが影響してるのかなぁと、xoopsはもちろん、プログラミングの素人のわたしは思うのですが、どうすればキャプチャ画像が出て、且つ正しく機能するようになるのか教えていただきたく、お忙しいところ恐縮ではございますが、何卒、何卒ご教示ををお願いいたします。

]]>
korekara 2013-12-08T03:15+09:00 XCL2.2
admanageのランダム表示とSSLページ対応について https://xoopscube.jp/forum/7172 お世話になります。XCL2.21でadmanageを使用しております。テーマにフルバナーのコード&lt;{$admanage.random}&gt;を貼り付けて確認しましたところ、問題点が複数ありました。1)ランダム表示がされない。IDの大きなバナーのみが表示され、その他のバナーが表示されません。2)SSL対応ページに行くとバナーが表示されない幾つかのモジュールにSSLをかけていますが、そのページへいくと画像が表示されません。これは絶対パス/相対パスの問題可と思うのですが、どのファイルを修正すればよいのでしょうか。どうぞよろしくお願い致します。

お世話になります。

XCL2.21でadmanageを使用しております。

テーマにフルバナーのコード<{$admanage.random}>を貼り付けて確認しましたところ、問題点が複数ありました。

1)ランダム表示がされない。
IDの大きなバナーのみが表示され、その他のバナーが表示されません。

2)SSL対応ページに行くとバナーが表示されない
幾つかのモジュールにSSLをかけていますが、そのページへいくと画像が表示されません。
これは絶対パス/相対パスの問題可と思うのですが、どのファイルを修正すればよいのでしょうか。

どうぞよろしくお願い致します。

]]>
atom-s 2013-12-05T19:24+09:00 XCL2.2
「ホーム」が正しく表示されない (真っ白またはエラー) https://xoopscube.jp/forum/7162 XOOPS Cube Legacy 2.2.2を利用させて頂いております.(CentOS6.5, Apache/2.2.15, PHP/5.3.3, mysql/5.1.69)複数人で共同作業しているため,どの作業内容が引き金になったのかは分からないのですが,http://xxx.xxx.xxx/xoops/にアクセスした場合に,・Firefox(25.0)だと画面が真っ白になる・IE(9, 10)だとHTTP 500エラーが出るの状況になってしまいます.但し,http://xxx.xxx.xxx/xoops/user.phpにてログインした場合は問題なく利用でき,ログアウトするまで「ホーム」も正常に表示されます(ログアウトするとまた異常な状況に逆戻りします).Apacheはerror_logを全く吐いてくれず,XOOPSの管理者メニューから「PHPデバッグ」をONにしても何もエラーメッセージを出さないので,どこを疑ってよいのか全く分かりません.素人目には,index.php→user.phpのリダイレクトがうまくいってないように見えるのですが,対処法や解決のヒントをご教示頂けませんでしょうか.宜しくお願い致します.

XOOPS Cube Legacy 2.2.2を利用させて頂いております.
(CentOS6.5, Apache/2.2.15, PHP/5.3.3, mysql/5.1.69)

複数人で共同作業しているため,どの作業内容が引き金になったのかは分からないのですが,

http://xxx.xxx.xxx/xoops/

にアクセスした場合に,

・Firefox(25.0)だと画面が真っ白になる
・IE(9, 10)だとHTTP 500エラーが出る

の状況になってしまいます.但し,

http://xxx.xxx.xxx/xoops/user.php

にてログインした場合は問題なく利用でき,ログアウトするまで「ホーム」も正常に
表示されます(ログアウトするとまた異常な状況に逆戻りします).

Apacheはerror_logを全く吐いてくれず,XOOPSの管理者メニューから「PHPデバッグ」を
ONにしても何もエラーメッセージを出さないので,どこを疑ってよいのか全く分かりません.

素人目には,index.php→user.phpのリダイレクトがうまくいってないように見えるのですが,
対処法や解決のヒントをご教示頂けませんでしょうか.

宜しくお願い致します.

]]>
tsumosan 2013-11-06T10:29+09:00 XCL2.2
ユーザ自身による退会に失敗が多発します https://xoopscube.jp/forum/7142 お世話になります。現在運営しているサイトで、ユーザ自身で退会処理をしたつもりが、アカウントが削除されずデータも残ったままになっている方が数名おります。その後サイトにアクセスし、試しに退会処理前のIDとパスを入力すると、ユーザ情報の画面は出るものの、他のブロック等はまるで表示されず、ただユーザ情報のみが画面に出ている状態となっています。これは何が原因なのでしょうか?ただ、正常に退会処理が完了しているユーザもおり、当方で考えられる原因としましては、退会処理に失敗したユーザは、携帯(ガラケー)からアクセスしていた可能性が高い、という事です。当方の状況・XCL 2.2.1 Beta2・PHPバージョン : 5.2.17ユーザープロフィールは、xsnsのプロフィールと同期させています。何か解決の糸口を見つけられたらと思っています。宜しくお願い致します。 お世話になります。

現在運営しているサイトで、ユーザ自身で退会処理をしたつもりが、アカウントが削除されずデータも残ったままになっている方が数名おります。

その後サイトにアクセスし、試しに退会処理前のIDとパスを入力すると、ユーザ情報の画面は出るものの、他のブロック等はまるで表示されず、ただユーザ情報のみが画面に出ている状態となっています。

これは何が原因なのでしょうか?

ただ、正常に退会処理が完了しているユーザもおり、当方で考えられる原因としましては、
退会処理に失敗したユーザは、携帯(ガラケー)からアクセスしていた可能性が高い、という事です。


当方の状況

・XCL 2.2.1 Beta2
・PHPバージョン : 5.2.17

ユーザープロフィールは、xsnsのプロフィールと同期させています。

何か解決の糸口を見つけられたらと思っています。
宜しくお願い致します。]]>
atom-s 2013-08-09T12:00+09:00 XCL2.2
SSLの設定について https://xoopscube.jp/forum/7134 初心者です。宜しくお願い致します。現在XCL 2.2.1 Beta2でサイトを作成しています。このたび独自SSLを導入する為、証明書を取得しました。証明書のインストールまでは上手く行ったのですが、XOOPSのSSL化で躓いております。私の希望としましては、新規登録・ログイン・プライベートメッセージ・問い合わせフォームなどを暗号化できればと考えております。gusagiさんのsslfilter preloadがある事を知り(サーバーがダウンしている様ですが)、ソースを探して導入してみたものの変化が起きない状態です。ログインのみSSLを利用する方法は一度実行して成功したのですが、ガラケーからログインしようとすると、SSLログインを選択していない場合でもログインに失敗するというエラーが発生した為、現在はSSLを外しています。sslfilter preloadを適用させる方法、またはそれに近い動作をさせる方法はないものでしょうか?宜しくお願い致します。 初心者です。宜しくお願い致します。

現在XCL 2.2.1 Beta2でサイトを作成しています。

このたび独自SSLを導入する為、証明書を取得しました。
証明書のインストールまでは上手く行ったのですが、XOOPSのSSL化で躓いております。

私の希望としましては、新規登録・ログイン・プライベートメッセージ・問い合わせフォームなどを暗号化できればと考えております。

gusagiさんのsslfilter preloadがある事を知り(サーバーがダウンしている様ですが)、ソースを探して導入してみたものの変化が起きない状態です。

ログインのみSSLを利用する方法は一度実行して成功したのですが、ガラケーからログインしようとすると、SSLログインを選択していない場合でもログインに失敗するというエラーが発生した為、現在はSSLを外しています。

sslfilter preloadを適用させる方法、またはそれに近い動作をさせる方法はないものでしょうか?

宜しくお願い致します。]]>
atom-s 2013-06-17T18:22+09:00 XCL2.2
500エラーでサイトが表示されなくなりました https://xoopscube.jp/forum/7135 さくらのマネージドサーバにて、XCL2.2.1でサイトを制作しています。モバイルでの表示を調整する為、hypcommonfuncモジュールの設定をしていた所、突然500エラーが出てサイトが表示されなくなりました。タイミングとしては、モバイル用テーマ選択の部分で、プルダウンメニューの中から「設定しない」という項目を選択した後にエラーが発生しました。サーバのエラーログを見るとPremature end of script headers: index.php と出ています。出来る限り早急に復旧させたいのですが、どういった方法を取ればよいのか、ご教授頂けましたら幸いです。宜しくお願い致します。 さくらのマネージドサーバにて、XCL2.2.1でサイトを制作しています。

モバイルでの表示を調整する為、hypcommonfuncモジュールの設定をしていた所、
突然500エラーが出てサイトが表示されなくなりました。

タイミングとしては、モバイル用テーマ選択の部分で、
プルダウンメニューの中から「設定しない」という項目を選択した後にエラーが発生しました。

サーバのエラーログを見ると
Premature end of script headers: index.php と出ています。


出来る限り早急に復旧させたいのですが、どういった方法を取ればよいのか、
ご教授頂けましたら幸いです。

宜しくお願い致します。]]>
atom-s 2013-06-20T17:49+09:00 XCL2.2
picoコンテンツ内にd3pipesの記事を表示する https://xoopscube.jp/forum/7114 picoのある一つのコンテンツ内にd3pipesの記事を表示させたいと思っています。例えば、d3pipes内のパイプ番号2の記事を取得する方法などありますか?各バージョンXOOPS:XLC2.20pico:1.82d3pipes:0.68 picoのある一つのコンテンツ内にd3pipesの記事を表示させたいと思っています。

例えば、d3pipes内のパイプ番号2の記事を取得する方法などありますか?

各バージョン
XOOPS:XLC2.20
pico:1.82
d3pipes:0.68]]>
nellson 2013-03-28T14:10+09:00 XCL2.2
プライベートメッセージのメール転送設定 https://xoopscube.jp/forum/7089 XOOPS Cube Legacy 2.2.2 Beta1を利用しつつ悪戦苦闘中です。XoopsXから追加された「プライベートメッセージ」の設定にあります「設定」から「メールに転送する」の機能をオンにして運用しています。イベントの通知をプライベートメッセージで受信するとXOOPSに登録したメールアドレスに転送されるようにと考えました。結果、転送されるユーザーと転送されないユーザーがいます。例えば同じGmailユーザーでも転送されるユーザーとされないユーザーがあり、有料のメールアドレスを使用していても転送されるユーザーとされないユーザーがいます。ユーザーグループは全員同じです。目標としては設定したユーザー全員のPM着信がメールに転送される形を目指しています。原因と解決する手段がございましたらご教授いただけないでしょうか。よろしくお願いします。 XOOPS Cube Legacy 2.2.2 Beta1
を利用しつつ悪戦苦闘中です。

XoopsXから追加された「プライベートメッセージ」の設定
にあります「設定」から「メールに転送する」の機能をオンに
して運用しています。
イベントの通知をプライベートメッセージで受信すると
XOOPSに登録したメールアドレスに転送されるようにと
考えました。
結果、転送されるユーザーと転送されないユーザーが
います。
例えば同じGmailユーザーでも転送されるユーザーとされない
ユーザーがあり、
有料のメールアドレスを使用していても転送されるユーザーと
されないユーザーがいます。
ユーザーグループは全員同じです。

目標としては設定したユーザー全員のPM着信が
メールに転送される形を目指しています。
原因と解決する手段がございましたらご教授いただけないでしょうか。
よろしくお願いします。]]>
utane 2013-02-19T18:42+09:00 XCL2.2
別クラスで$xoopsDBを使用する方法 https://xoopscube.jp/forum/7070 基本的な質問かもしれませんが、よろしくお願いします。モジュールのadminフォルダの下にtest1.phpとtest2.phpがありtest1.phpのほうで$xoopsDB-&gt;fetchArrayなどしてテーブルデータを取得しtest2.phpに渡して処理しているのですがこれをtest1.phpでsql文だけ作ってtest2.phpで$xoopsDB-&gt;fetchArrayなどの処理をやらせようとしているのですが(同じ処理を一元化するため)test1.phpだと何も考えずに、$xoopsDBが使えたのですがtest2.phpで$xoopsDBを使用する場合、どのようにすればよいのでしょうか? 基本的な質問かもしれませんが、よろしくお願いします。

モジュールのadminフォルダの下にtest1.phpとtest2.phpがあり
test1.phpのほうで$xoopsDB->fetchArrayなどしてテーブルデータを取得し
test2.phpに渡して処理しているのですが
これを
test1.phpでsql文だけ作って
test2.phpで$xoopsDB->fetchArrayなどの処理をやらせようとしているのですが
(同じ処理を一元化するため)
test1.phpだと何も考えずに、$xoopsDBが使えたのですが
test2.phpで$xoopsDBを使用する場合、どのようにすればよいのでしょうか?]]>
kimura0118 2012-12-03T04:18+09:00 XCL2.2
お問い合わせ モジュール https://xoopscube.jp/forum/7068 こんにちはXOOPS Cube 2.2を使用しており、お問い合わせフォームのような機能があるモジュールを探しております。質問内容を選択して、本文入れて、管理者に送信できればいいとおもっているのですがおすすめのモジュールなどありますでしょうか? こんにちは
XOOPS Cube 2.2を使用しており、
お問い合わせフォームのような機能があるモジュールを探しております。

質問内容を選択して、本文入れて、管理者に送信できればいいとおもっているのですが
おすすめのモジュールなどありますでしょうか?]]>
kimura0118 2012-11-25T18:06+09:00 XCL2.2
プロフィールを https://xoopscube.jp/forum/7069 こんにちは、管理画面の新しいプロフィール定義を追加で新しいプロフィール項目を追加はできるのですが仮に、興味という項目を追加しバイク、車、飛行機、鉄道など 興味があるものにチェックしてもらいプロフィールに登録してもらおうと思っているのですが一つのプロフィール項目に複数のチェックボックスを表示させることは可能でしょうか?編集方法などありました、教えてください。(一つのプロフィール項目にひとつのチェックボックスは入れられるようなのですが。)文章入力の際の顔アイコンの横にある[もっと...]押すと、別ページが開いて選択したのが反映するみたいな感じでもいいと思ったのですが。最初は簡単なほうでいこうかと。 こんにちは、
管理画面の新しいプロフィール定義を追加で
新しいプロフィール項目を追加はできるのですが
仮に、興味という項目を追加し
バイク、車、飛行機、鉄道など 興味があるものにチェックしてもらい
プロフィールに登録してもらおうと思っているのですが
一つのプロフィール項目に複数のチェックボックスを表示させることは可能でしょうか?
編集方法などありました、教えてください。
(一つのプロフィール項目にひとつのチェックボックスは入れられるようなのですが。)

文章入力の際の顔アイコンの横にある[もっと...]押すと、別ページが開いて
選択したのが反映するみたいな感じでもいいと思ったのですが。
最初は簡単なほうでいこうかと。]]>
kimura0118 2012-11-26T01:52+09:00 XCL2.2
XCL2.2.1のzipdownloader.phpでエラー https://xoopscube.jp/forum/7050 お世話になっています。XCL2.2.1のzipdownloader.phpでエラーが発生します。html/class/zipdownloader.phpの82、83行目header(\&#039;Content-Type: application/zip\&#039;) ;header(\&#039;Content-Length: \&#039;.floatval(@strlen($file))) ;の&quot;\&quot;が付いているため、PHPがエラーとなります。header(&#039;Content-Type: application/zip&#039;) ;header(&#039;Content-Length: &#039;.floatval(@strlen($file))) ;にするとエラーは消えます。以上、報告します。動作検証環境Windows Server2008(x64)日本語版 SP2IIS7.0PHP 5.2.17(FastCGI)x86MySQL 5.1.62(x64) お世話になっています。

XCL2.2.1のzipdownloader.phpでエラーが発生します。

html/class/zipdownloader.phpの82、83行目

header(\'Content-Type: application/zip\') ;
header(\'Content-Length: \'.floatval(@strlen($file))) ;

の"\"が付いているため、PHPがエラーとなります。

header('Content-Type: application/zip') ;
header('Content-Length: '.floatval(@strlen($file))) ;

にするとエラーは消えます。

以上、報告します。

動作検証環境
Windows Server2008(x64)日本語版 SP2
IIS7.0
PHP 5.2.17(FastCGI)x86
MySQL 5.1.62(x64)]]>
pcboy 2012-08-02T22:47+09:00 XCL2.2
Xmovie https://xoopscube.jp/forum/7013 XC Legacyバージョン : XOOPS Cube Legacy 2.2使用言語 : ja_utf8オペレーティングシステム : Linux sサーバー : ApachePHPバージョン : 5.1.6MySQLのバージョン : 5.0.77はじめまして。初心者ですがxoopsでサイト構築中です。Xmovieを使用していますが、languageに ja_utf8がありません。ja_utf8が付いたXmovieは無いのでしょうか?申し訳ございませんが、どなたかご教示いただけないでしょうか。よろしくお願い致します。 XC Legacyバージョン : XOOPS Cube Legacy 2.2
使用言語 : ja_utf8
オペレーティングシステム : Linux s
サーバー : Apache
PHPバージョン : 5.1.6
MySQLのバージョン : 5.0.77

はじめまして。

初心者ですがxoopsでサイト構築中です。

Xmovieを使用していますが、languageに ja_utf8がありません。

ja_utf8が付いたXmovieは無いのでしょうか?

申し訳ございませんが、どなたかご教示いただけないでしょうか。

よろしくお願い致します。]]>
cube0811 2012-04-16T19:01+09:00 XCL2.2