ホーム > nao-pon

nao-pon

記事一覧 > XOOPSマニア::xpWiki::Dev/xpWiki開発日記 > xpWiki 5.02.28 から PHP 5.3 未満では動作しなくなります

xpWiki 5.02.28 から PHP 5.3 未満では動作しなくなります

Changes

#snsref(http://hpwb.net/2hBl7HQ

2017 10月 11 (水)
 

xpWiki 5.02.28 から PHP 5.3 未満では動作しなくなります anchor.png Edit

module_icon.pngTag: アナウンス

PHP 7.2 対応のため、xpWiki は次回のバージョン 5.02.28 から PHP 5.3 未満では動作しなくなります。

その理由の一つとして `create_function` 関数が PHP 7.2 から非奨励になることがあげられます。`create_function` 関数の代わりに PHP の無名関数構文を使用しますが、これが PHP 5.3 未満では動作しないためです。

未だ PHP 5.3 未満の環境の方はほぼいないと思いますが、ご承知おきください。

To Top